Sign in to follow this  
Followers 0

New Baja Cage Extension from Speed Industries

1 post in this topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • By crazynordlander
      Hi All,
      I live in Minnesota and bought a 2016 CFORCE 500 HO. I am in hope to see if there is anyone in the US that is experiencing this sudden drop off in RPM below 4000 RPM. I have uploaded some videos of my issue on YouTube. I will list three of the four I posted. The fourth can be found on my channel but it is a comparison between my Polaris 570 and my CFORCE 500.
      I quit on my first dealer because we just did not mix well together. I brought it to another CFMOTO dealer that just became a CFMOTO dealer in January 2016. They are in a large ranch and agriculture area in a neighboring state that is pretty close to where I live. They have close to every brand available. They are a much larger dealer than the first one I bought the unit from.
      I brought the unit three weeks ago to them and they have worked on it a good solid week and have given up on it. I have read reports from owners in Canada that the dealers there were aware of the issue and have had success in fixing the herky jerky drivability issue.
      I am picking it up tomorrow and bringing it back home. It has been to the trails of the Black Hills this year and was new in late April. 300 miles on it. It has never changed. Very hard to ride on the trails or when I herd livestock.
      Here are the links to my videos.

      I can't accept that this is normal operation. Does anyone from CFMOTO China scan these posts?
      I need help that CFMOTO USA has not provided.
    • By Beckbrenden
      My 20005 Prarie 700 won't go over 27-31 mph and actually loses power when you give it all the throttle it has, anyone have any ideas or ever had this problem before?
    • By Beckbrenden
      My 2005 Kawasaki Prarie 700 is not functioning as it should, has no speed, no power and backfires when slowing down, I've cleaned the carb...completely, cleaned the fuel filter, it has new spark plugs, it won't idle also and has recently become hard to start, I adjusted the idle but still no results, any help or suggestions would be greatly appreciated
    • By WeekendATVdotcom
      If youve looked at some of the factory mud machines youve noticed many have upgraded footpegs to help keep your feet firmly grounded. Rox Speed FX released universal foot pegs earlier this year for anyone. See what you think of them: REVIEW: Rox Speed FX ATV Foot Pegs -

    • By YamahaWolverine
      So I was reading and a stock 2003 wolverine 350 should top out at 55 MPH and mine only does 44? What could be dragging it down? Any ideas appreciated. Btw I'm new here so hello everyone! I hope this forum is better than the others that I joined.