austin1869

Suzuki LT250R wiring diagram

4 posts in this topic

My brother and I recently purchased an old 250r, with the intent of rebuilding it. We need a wiring diagram, would anyone know if there is one posted online, or would anyone have a copy they could scan and email to me? I am going to try to post some pictures of it when I get time, any ideas, questions, comments or concerns would be a big help.

Share this post


Link to post
Share on other sites


My brother and I recently purchased an old 250r, with the intent of rebuilding it. We need a wiring diagram, would anyone know if there is one posted online, or would anyone have a copy they could scan and email to me? I am going to try to post some pictures of it when I get time, any ideas, questions, comments or concerns would be a big help.

Unfortunately I do not have anything that goes back that old for Suzuki. You should just invest in a $20 manual. I looked at some of my online sources also, but could not find one. If I come across one, I will post it up.

Share this post


Link to post
Share on other sites

What year LT205R did you get? I may have the diagram.

Share this post


Link to post
Share on other sites

Yeah my brother has a book but he can't find it, I am gonna give him another week and then purchase another one if I need to. Scott; we think we got a miss match. the date on the frame is 11/85 so I think that would mean an 86 produced in late 85 but not certain. also I don't think the 86 had a powervalve and this one does so I think the motor may be an 87 but once again I am not sure. let me know if there is anymore info you may need and keep the info coming its appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By evlsnke
      loud clicking, snapping noise under load when accelerating.
    • By Steve1266
      I went out to ride my quad today. When I started it up it ran for a minute, then died. Since then it will turn over but won't start. I've check the spark plug and get great fire. I have had this quad for about 6 months, and very new to breaking it down. But need help. Thanks
    • By JPRICE1981
      Hello everyone !! Looking for some help !! Im wanting to check my stator and pick up coil with a ohm meter and cant seem to find a guide that tells me what to read and what my reading should be !! Any help would be great !! THANKS IN ADVANCE !!
    • By RichUncleSkeleton
      Hello
      Just signed up, as I've had a recurring problem, and need some help.
      To start the bike I have to put the choke on all the way and 4 squeezes on the gas, Then as I push the start, I slow squeeze the throttle about half way for it to catch....If I miss it, then it will take 5 mins of slowly finding the sweetspot on the choke in unison with some throttle squeezes.
      Then I have to to hold the throttle to keep the bike going, using the choke will stall it out. after about 3 mins of holding the throttle, I then can let it go, and it idles fine, and runs fine. If it sits for a few hours it's only slightly hard to start, but a few days of sitting, and it's a lot more work.
      Had the bike serviced they couldn't figure it out. They swapped peticock, plug, new gas, all new lines, new throttle, and cable. Said the carb was fine, and clean. New air filter, said fuel pump was fine, no leaks around carb boots, new battery, new rectifier.
      Ran some sea foam through it....Runs Great.....Just such a pain to start...
      Thanks