kquerel

2007 arctic cat 700 EFI Flashing Display Screen

4 posts in this topic

Hello All,

I'm new to this Forum! I have read all the rest of the posting pertaining to the display screen, I do have similar issues and I need all of your help!

First off the atv starts and runs fine but when I turn the key on the display flashes until I push the "select" button, then everything is normal on the display. When I start riding the screen starts flashing again.

I have checked the connections (used connection cleaner), charged the battery to full, unhooked the battery over night, but it still flashes and does the same thing.

Things I still have to try:

- changing the gas and putting fresh gas in it

- changing the spark plug

- checking the belt (not sure if it’s the correct one or not but it runs fine)

Is there anything else that I have missed?

Does anyone have a PDF of the owner’s manual?

Thanks for your advice!

Share this post


Link to post
Share on other sites


I don't really know what to suggest about your problem, but I have noticed that there is more than one person here who has posted about the same problem with the same exact machine.

http://www.quadcrazy.com/atvforum/arctic-cat-atv-forum/7477-2007-arctic-cat-700-efi-wont-run.html

http://www.quadcrazy.com/atvforum/arctic-cat-atv-forum/7343-2007-arctic-cat-700-efi-4x4-digital-display-not-working.html

Edited by DirtDemon

Share this post


Link to post
Share on other sites

artic cat has alot of problems with there displays

pin point issue by replacing display with known good one

this will allow you to tell if its a wiring problem or a switch power issue

aiticat had issues with wiring

i just remember having a problem like that from a new unit

turned out to be temp sensor wire shorting to ground as i was

replacing harness

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By toonces
      I'm wanting to run Shell Rotella T6 synthetic in the 700 Griz but I can only find it in either 0W-40 or 5W-40 weights, and the manual says it's ok to use everything BUT those weights...5W-30, 10W-30, 10W-40, 15W-40, 20W-40 and 20W-50.
      Would it be ok to use the Rotella 5W-40 or do I need to stick to what's specified in the manual?
    • By chevyboy
      AL righty I did some trading around this weekend and ended up picking up a few 4 wheelers for cheap. I ended up with this one for $500 in it total and well the guy told me it dropped a valve. I haven't really messed with it at all. But this weekend I am going to try and start working on it some to get it running before winter time frame. So what I am asking is a couple of questions.
      1. First off where do I start I tried pulling the pull cord and could not get it to move at all.
      2. I need to get a service manual for this 4 wheeler where can I get it downloaded for free?
      3. what do I need to look for and how do I go about this really. I do have experience with 4 wheelers but this one is a little different to me than others because its a V2 and I have no clue where to start internal on the engines. Most of my experience is on the outside portion of troubleshooting on theses wheelers.
      Please no smart butt answers as i am new to here but just wanted opinions on where to start. Please and thanks wink:
    • By bodatiouskid
      Have a 2002 Polaris Sportsman 700 that only has 34mi. on a carb & ring job.
      Cut the gas off today to drain carb.Now engine will not idle.If I open throttle will run,but let off & will cut off.Can screw idle in with no change.
      What happened? Why did this happen when fuel ran out?
      Please help me,my ATV is a daily driver.
      Please help!!