jbthunderbird

2007 Arctic Cat 500 LCD Display Problems

6 posts in this topic

Hi I was wondering if I could replace my 2007 500's LCD Display with a 2007 700's display, would there be any problems, would it fit, my 500's LCD display is not working properly only a 1/4 of it is working. I would greatly appreciate any help you can give thinks or any good alternatives

Share this post


Link to post
Share on other sites


Good question. What I woudl do is call the dealer and see if the connections are the same and teh unit is the same part #.

* Added year, make, and model to your thread title.

Share this post


Link to post
Share on other sites

The 700 has a different part #, but the 650 has the same one as the 500.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By chevyboy
      AL righty I did some trading around this weekend and ended up picking up a few 4 wheelers for cheap. I ended up with this one for $500 in it total and well the guy told me it dropped a valve. I haven't really messed with it at all. But this weekend I am going to try and start working on it some to get it running before winter time frame. So what I am asking is a couple of questions.
      1. First off where do I start I tried pulling the pull cord and could not get it to move at all.
      2. I need to get a service manual for this 4 wheeler where can I get it downloaded for free?
      3. what do I need to look for and how do I go about this really. I do have experience with 4 wheelers but this one is a little different to me than others because its a V2 and I have no clue where to start internal on the engines. Most of my experience is on the outside portion of troubleshooting on theses wheelers.
      Please no smart butt answers as i am new to here but just wanted opinions on where to start. Please and thanks wink:
    • By Wonderwoman
      Hello, well back to where I was last year with this carb. Took my 250 to the mountains for the first time this year and blue smoke, too much gas again. I can't believe that this carb gives me this much trouble. Seems like the choke is stuck but the cable moves freely. Anyone else ever experience this issue? Do you think a new choke cable would maybe resolve this?http://www.quadcrazy.com/atvforum/images/smilies/arghh.gif
      OK it was the choke. Put on all new cable and plunger and she is running 100% again. So now the question is, is the carb getting worn out where the plunger needle goes in the small hole and when I use the choke the needle end doesn't get lined back up with the hole?? We'll see how it runs and now that I know what the issue is I can always pull the choke plunger out and reinstall if I start having this issue again.