speedy

2007 honda rancher 420 efi wont start

3 posts in this topic

Hi

I took my atv apart to repaint all the plastics and after putting it all back together it wont start i didnt take anything major apart just unpluged the battery, one of the silinoid wires and the tail light plug so im sure everything is back the way it was before i took it apart.

when i press the start botton the silinoid makes a buzzing sound and there is no spark, i already tried replacing the silinoid but it still does the same thing. i also tried push starting it and it will start(but no throttle response) but as soon as you stop pushing it the motor shuts off.

i would very much appreciate any help thanks

Share this post


Link to post
Share on other sites


Go over your steps, sounds like you left something unplugged somewhere. When you say no spark, do you mean the starter will not turn?

Share this post


Link to post
Share on other sites

I have gone over everything 20 times thinking the same thing but everything is connected. it does sound like the starter is turning but im guessing that its not since no spark and the motor does not turn over. after figuring that i thought maybe the starter just happened to go bad at that time but still the engine will not stay running after being push started.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By sloundez
      Does anyone out there know where I can get a functional pair of wheel cylinders for subject ATV? Any suggestions welcomed. Thanks
    • By Suzuki24
      I have an 04 ltz and it started sputtering a little bit while going down the road and I was low on gas so I just figured that's what it was. But now I can't get it to start I completely cleaned the carberator put a new spark plug and coil pack in it and all it does is turn over. It has compression it's getting fuel and it is sparking but all it does is turn over any idea what it is??
    • By marcuslachance
      I
      I bought a Honda 250sx 1986 but the exhaust is broken. Apparently it's not possible to order a new one. I checked to order one on others compagny but there's noting.
      Do you know which exhaust it's possible to install. Is there a company who sold an exaust to fit on my 250sx.
      Sorry for my english
      Thank you
      Marc
    • By izzydum1
      Any ideas on what would make a coil not fire? She was running fine, then began slow start. Now wont start at all.
    • By Npeters
      Im working on a old 1987 honda 125 4 wheeler in the school shop. It will start by getting pulled by another 4 wheeler but wont start with the pull start or Electric Start. When you pull start it it tries to start but when you try the electric start it just turns over but doesnt even act like it wants to start. The spark plug is dry and it shoots fuel out of the back(air filter side) of the carb. Weve had the carb off twice and it is complety clean. What are some things we can try?