6 posts in this topic

That is absolutely awesome, by far the best side x side ever. I would definately buy one of those if I could.

Share this post

Link to post
Share on other sites

Now if only I could afford one. I think my wife would love it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Sniderman
      Any one have advice or tips on installing a rear motor mount on 93 trail boss 350 2x4'
    • By joehelf
      Where is the best place for a new camshaft for a 2000 Polaris Sportsman 500 RSE?
      I figured some of the quad owners on this forum have probably bought them before as this is a common problem on the Polaris 500. My exhaust cam lobe is almost completely wore down and the thing hardly will even get up an go.
      I like other's opinions rather than just "buying on the fly". If any of you guys have a good suggestion I'd be interested in getting a good one at a fair price.
      2000 Polaris Sportsman 500 Remington Steele Edition
    • By kingjosk12
      A week ago I could not even get close to starting it. But now I adjusted the valves (exhaust valve was not closed). i got it running but would not run without choke. i adjusted the float because it was to low tried starting it up again and it would not even start. So i went back and looked at the valves and the valve was now open again so i adjusted it and it started right up and ran perfect without choke. So i put it all back together thinking it was ready to go. Started it up and let it run for a little bit. i turned it off and tried starting it again there was NOTHING. took it apart and there was 0 compression and the exhaust valve was open again. I am completely lost need help PLEASE!!!:aargh:
    • By mothrottle
      I'm new to this forum and I hope you can help me out. My '99 Polaris 250 Trail boss does this: shifting in to forward the gears grind a bit. Once in gear the rig wants to immediately move forward. If I don't get to the throttle fast enough, she stalls.If I do, off we go. It happens everytime I shift into gear.Could this be caused by dirt inside the clutch sheaves causing the belt to engage early (before any throttle input)? Or what??? Thanks in advance.
    • By Earthmover
      Hey im looking forward to getting a new
      Quad. Im looking at for bikes
      utility Vs race for starters and
      Can-am 1000 Vs Polaris 1000 i have videos around so yous can get an idea of my riding style if yous care to check them out and yeah let me know what yous think or what you would bye. thanks