Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Where To Ride Your ATV

Discussion forum on where to ride your ATV. Where do you ride? You can also post in our Regional Forums for specific locations by state and region. 

194 topics in this forum

    • 2 replies
    • 2,455 views
  1. New offroad park coming to Foley, MO

    • 7 replies
    • 5,638 views
    • 0 replies
    • 1,378 views
  2. Trails added at Doc Hilt

    • 0 replies
    • 1,072 views
  3. Ridge runner club ride

    • 1 reply
    • 1,414 views
  4. Map with the states you have rode in

    • 7 replies
    • 1,677 views
    • 0 replies
    • 223 views
  5. holloween trail and hay ride

    • 4 replies
    • 1,487 views
  6. Roadtrip Take 3

    • 9 replies
    • 1,220 views
  7. swap meet

    • 1 reply
    • 1,375 views
  8. New mud Doc Hilt Trails

    • 0 replies
    • 1,132 views
  9. New web page for Doc Hilt Trails

    • 0 replies
    • 1,108 views
    • 2 replies
    • 1,837 views
  10. A few of my friends

    • 0 replies
    • 1,015 views
  11. Cloud Nine Ranch

    • 0 replies
    • 1,362 views
    • 0 replies
    • 2,602 views
  12. Trevorton

    • 11 replies
    • 6,925 views
  13. Riding in Southern Illinois

    • 2 replies
    • 1,860 views
  14. April 2009 Pismo Trip

    • 6 replies
    • 1,278 views
  15. Where I Ride

    • 4 replies
    • 1,289 views
  16. boycott burning rock atv

    • 18 replies
    • 7,562 views
    • 0 replies
    • 1,674 views
  17. 'tween B'ham & Atlanta riders

    • 2 replies
    • 1,307 views
    • 0 replies
    • 993 views
  18. A list of OHV Areas and Tracks

    • 3 replies
    • 1,483 views
    • 19 replies
    • 3,385 views
  19. 2009 Trips

    • 3 replies
    • 1,220 views
  20. Trail Pass - ATV trail system

    • 7 replies
    • 2,262 views
  21. Hollister this weekend 1-10

    • 1 reply
    • 1,186 views
  22. Washington Riders ~ Where Do You Ride?

    • 4 replies
    • 3,022 views
  23. 2009 Riding Trips

    • 16 replies
    • 2,046 views
  24. Pismo Ride 1 2 3 4

    • 81 replies
    • 6,462 views
  25. halloween?

    • 22 replies
    • 3,108 views
  26. practice at Dirty South MX

    • 1 reply
    • 1,308 views
    • 1 reply
    • 1,095 views
    • 0 replies
    • 1,328 views
    • 20 replies
    • 5,815 views
  27. Eureka!

    • 7 replies
    • 1,715 views
  28. Labor Day Weekend Ride

    • 18 replies
    • 2,189 views
  29. We need an ATV Trail Section

    • 15 replies
    • 2,210 views
  30. What kind?

    • 17 replies
    • 2,184 views
  31. Trails

    • 23 replies
    • 8,499 views
  32. Who's ridin' for Fathers Day?

    • 8 replies
    • 1,483 views
    • 4 replies
    • 1,783 views
  33. Busco Beach Mud Bash

    • 0 replies
    • 2,071 views
    • 4 replies
    • 1,395 views
    • 3 replies
    • 1,263 views
  34. South East Missouri

    • 0 replies
    • 1,393 views
    • 1 reply
    • 1,234 views
  35. Lets hit Hollister Hills 4/26/08, anyone?

    • 2 replies
    • 1,252 views


  • Latest Forum Posts

    • If it’s been taken apart already you might be fighting a loosing battle.  Meanwhile I would start looking up a used one on eBay and be ready to order if yours is beyond repair.  Like I said before your committed at this point so might as well finish it right.  Nice work so far brother.  
    • great info Frank.  I was looking at the starter switch to see how it even comes apart and I noticed it's of course missing 2 of the screws that hold it on, so it's been apart before I'd say.  I'll start with taking it apart to clean.  Heck I've cleaned every other thing on this bike, so may as well clean inside of that switch too.
    • Nice work.  So the sensor appears to be good. Now all you need to do is let it run and get to temp and see if the fan comes on.  Just keep in mind that if that thermostat is not opening then the coolant will not circulate and never reach the temp and bring the fan on! So be aware of that.    If you have an infrared thermometer you can aim and point at the head of the engine and the radiator to see what the temp differences are between the two and also check as the engine gets hotter to where the sensor temp that brings the fan on.  So if that sensor closes at 186 deg and your shooting the head of the engine with the thermometer as it nears that 186 or whatever that sensor is designed at then the fan should come on.  As far as the kill switch goes there are contacts inside, they are either dirty or just shot! You can test the switch with a tester on ohms/continuity. Trace the wires coming from the handle bar. There should be plugs right under the handlebars. Unplug the kill switch wires, connect your tester to the wires coming from the switch and flip the kill switch back and forth a few times you should get a reading on the tester when the switch is in the off position. My guess is it’s dirty inside. Open it up spray the shit out of it with contact cleaner.      
    • I've been using this site: https://www.rockymountainatvmc.com/oem-parts   Can search by year/model, then break it down per diagram.  I've ordered the majority of the parts for my bike rebuild and have received all of them next day.
    • just an update - I jumped the 2 wires on the fan relay switch like you suggested Frank and fan came right on, so I'm going to assume all is well there.  I also set the fuel/air mixture screw to 2-1/4 turns per factory spec and put the plastics back on the bike.  I started it and let it idle a few times and it is idling fine; I just haven't had a chance to actually take it for a ride.  Hopefully it's good to go now as far as running.   I'll go ahead and replace the thermostat in the near future as well. 1 other issue I've noticed all along but haven't mentioned and had put to the bottom of the list of issues....... the starter switch control button on the left handle; I've noticed that when the bike is running, if I flip the switch to the X position to kill the engine that it does not work.  Apparently the switch is bad??  The starter relay solenoid was one of the very first things I replaced on the bike when I first bought it, so I know it's not that.  I tired unplugging the harness that plugs into the top of relay solenoid with the bike running as I saw suggested in another thread and it doesn't kill the engine either.  Thoughts??  I probably won't mess with this right now as I've already spent enough $$ on the dang thing for the time being, but definitely want to research and fix it in the near future.

×
×
  • Create New...