Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Polaris ATV Forum

Posts about Polaris atv models and manufacturer specific topics.

832 topics in this forum

    • 0 replies
    • 2,096 views
    • 1 reply
    • 5,228 views
    • 9 replies
    • 1,796 views
  1. Terminal board 2000 xplorer

    • 1 reply
    • 1,070 views
    • 4 replies
    • 5,913 views
    • 34 replies
    • 21,597 views
    • 2 replies
    • 218 views
    • 2 replies
    • 537 views
  2. Trail Blazer 250 , New Member !

    • 3 replies
    • 1,706 views
    • 0 replies
    • 1,676 views
    • 2 replies
    • 7,479 views
  3. Trailblazer 250 revving and PVT problem.

    • 2 replies
    • 2,387 views
    • 2 replies
    • 2,354 views
    • 0 replies
    • 218 views
    • 4 replies
    • 364 views
    • 0 replies
    • 3,585 views
    • 2 replies
    • 489 views
    • 9 replies
    • 3,307 views
    • 5 replies
    • 2,233 views
    • 0 replies
    • 2,903 views
    • 21 replies
    • 12,941 views
    • 0 replies
    • 1,020 views
    • 4 replies
    • 2,046 views
  4. Wheels

    • 1 reply
    • 1,041 views
    • 1 reply
    • 1,392 views
  5. Why Polaris?

    • 4 replies
    • 1,298 views
  6. winch and plow stuck

    • 11 replies
    • 2,685 views
    • 3 replies
    • 1,194 views
    • 6 replies
    • 5,600 views
    • 28 replies
    • 394 views
    • 10 replies
    • 527 views


  • Latest Forum Posts

    • yea definitely worth cleaning and lubing the connections.  works great for hard-to-find bad connections.  good luck with that bike!!  wiring isnt really my strong point so ima back out at this point.. ...and watch and learn lol
    • Still scratching my head on this stupid thing.  I replaced the fan relay circuit and fan relay switch and still no fan.  I unplugged the fan with the bike running and hooked test light to the plug.  Shouldn’t the blue wire have power to it?  Or does it only send power when it needs to turn the fan on?  Maybe I didn’t run it long enough??  The harness below is what comes from main wiring harness and runs to the relay switch and fan and down to 4wd actuator.  I checked the wires on the backside of this harness with bike running as well and the only wire that has power is the red wire.  Does that sound right?
    • I recently bought a 2008 Kawasaki Teryx LE 4x4. It is an old beast, but in super good condition with only 30 original hours on it. It belonged to an old man who used it to check his mail some days. I have a very steep piece of property and intend to use it as a light weight tractor. I would also like to score a spare set of wheels to mount some Turf-type tires on it. Every now and then I may use it as a patrol vehicle when working a large property. I am a semi-retired cop and do this kind of work on the side. My intentions are to mount lights, a winch, and perhaps a stereo to it. Other than that, I am afraid that stock will be good enough for me!
    • Great review! I find the fuel level viewing window on my 2008 to be completely unreadable.

×
×
  • Create New...