Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Polaris ATV Forum

Posts about Polaris atv models and manufacturer specific topics.

873 topics in this forum

  1. Free Polaris ATV Manuals 1 2 3 4 6

    • 146 replies
    • 236,144 views
    • 290 replies
    • 150,813 views
  2. Polaris ATV Valve Adjustment

    • 16 replies
    • 30,307 views
  3. Polaris ATV VIN Number Decoder & Search

    • 4 replies
    • 28,854 views
  4. Polaris ATV VIN Number Decoder

    • 0 replies
    • 26,940 views
  5. How to set wheel alignment.

    • 8 replies
    • 16,292 views
  6. Polaris Online Parts Catalog

    • 8 replies
    • 8,946 views
    • 12 replies
    • 31,453 views
    • 14 replies
    • 30,661 views
    • 26 replies
    • 29,590 views
    • 7 replies
    • 29,058 views
    • 15 replies
    • 27,226 views
  7. 1993 Polaris 350L Trail Boss

    • 19 replies
    • 26,601 views
    • 5 replies
    • 23,375 views
  8. 2000 Polaris Sportsman 500 - DEAD / HELP

    • 6 replies
    • 22,648 views
    • 34 replies
    • 21,734 views
    • 7 replies
    • 21,053 views
    • 5 replies
    • 20,327 views
    • 8 replies
    • 19,520 views
  9. 2009 Polaris Sportsman 500 EFI overheating

    • 10 replies
    • 18,301 views
    • 20 replies
    • 18,150 views
    • 3 replies
    • 17,743 views
  10. 2" lift kit for Sportsman 500

    • 11 replies
    • 17,491 views
    • 7 replies
    • 17,428 views
    • 6 replies
    • 16,038 views
    • 15 replies
    • 15,705 views
    • 4 replies
    • 15,645 views
  11. 2002 Polaris Xpedition 425 ATV

    • 7 replies
    • 15,631 views
  12. 2006 Sportsman 450 crapping out

    • 17 replies
    • 15,629 views
  13. 2001 Polaris Sportsman 90

    • 15 replies
    • 15,066 views
    • 10 replies
    • 15,002 views
    • 25 replies
    • 14,976 views
  14. 1994 Polaris 400 4x4

    • 7 replies
    • 14,933 views
    • 17 replies
    • 14,730 views
    • 8 replies
    • 14,401 views
    • 4 replies
    • 13,863 views
  15. Polaris Predator 90 oils

    • 8 replies
    • 13,782 views
    • 5 replies
    • 13,753 views
    • 21 replies
    • 13,586 views
    • 9 replies
    • 13,281 views
    • 10 replies
    • 13,204 views
    • 3 replies
    • 13,157 views
    • 6 replies
    • 13,116 views
  16. 1994 sportsman 400 4 x 4 won't engage

    • 8 replies
    • 13,091 views
    • 9 replies
    • 13,030 views
    • 3 replies
    • 12,936 views
    • 5 replies
    • 12,734 views
    • 8 replies
    • 12,693 views
    • 4 replies
    • 12,678 views
    • 9 replies
    • 12,518 views


  • Latest Forum Posts

    • On mine I had to loosen up the foot pedal adjustment, I guess it needed to move more. I adjusted my rear brakes and that's what caused the problem, after loosening them up  it worked again, Also had to be in 1st in order to go into reverse. Seemed to be a problem an each Yamaha I have owned. Just got rid of one and same issues. 
    • and I did have to add grease to both ends of the rubber piece between air box and carb - maybe it's this burning off....?  i'll get it out from my crawl space this weekend if it's dry and let it run a bit - the wife was pretty angry about the smoke  "but honey, I didn't know it was gonna smoke like that!" if it's beyond repair and I can get a few hundred clams out of it, tell me - I can take it.  it's a 1999 and has 6100 miles on it
    • thanks for joining in, spock - yes, I know the part you're talking about - it went back in easily - and I tested it by turning it back/forth to ensure it remained operable prior to starting engine I reattached everything - had to sprinkle gas in air box but it started. it idled pretty rough - but it smokes like rip - white smoke - it also would rev slightly higher without me having touched the gas lever, then would go back to normal idle. it smoked a bit when I got it but not like this... I know it could be several things, but could it be the clean carb being "broken in" - if so, i'd expect the smoke to dissipate after a while air filter is new and gas is fresh the whining noise I am unsure about....   KQ first run after carb rebuild.MOV
    • Not to sound stupid but which one? Cause the left one which is for the rear I believe, is stuck. 

×
×
  • Create New...