Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Polaris ATV Forum

Posts about Polaris atv models and manufacturer specific topics.

873 topics in this forum

    • 1 reply
    • 2,308 views
    • 3 replies
    • 5,059 views
    • 9 replies
    • 619 views
    • 3 replies
    • 8,319 views
    • 1 reply
    • 1,480 views
    • 7 replies
    • 5,511 views
    • 6 replies
    • 16,031 views
    • 3 replies
    • 2,698 views
    • 2 replies
    • 2,281 views
    • 1 reply
    • 5,187 views
  1. predator 90 carb

    • 4 replies
    • 1,662 views
    • 2 replies
    • 181 views
  2. pulse coil

    • 0 replies
    • 1,316 views
    • 5 replies
    • 2,339 views
    • 6 replies
    • 2,147 views
    • 5 replies
    • 1,597 views
    • 0 replies
    • 1,765 views
    • 2 replies
    • 391 views
    • 0 replies
    • 3,703 views
    • 9 replies
    • 2,838 views
    • 0 replies
    • 270 views
  3. RZR overheats!

    • 0 replies
    • 210 views
    • 1 reply
    • 1,316 views
    • 1 reply
    • 2,735 views
    • 0 replies
    • 2,234 views
  4. Service Manual

    • 4 replies
    • 1,380 views
    • 0 replies
    • 1,291 views
  5. setting carb new throttle cable

    • 4 replies
    • 7,120 views
    • 16 replies
    • 6,654 views
    • 0 replies
    • 1,561 views
  6. Snow Plow on a 500 scrambler?

    • 4 replies
    • 3,932 views
    • 3 replies
    • 12,933 views
    • 1 reply
    • 829 views
    • 6 replies
    • 3,651 views
    • 2 replies
    • 248 views
  7. sportsman 500 6x6

    • 1 reply
    • 212 views
    • 3 replies
    • 348 views
  8. Sportsman 90

    • 1 reply
    • 1,041 views
    • 2 replies
    • 2,487 views
    • 3 replies
    • 1,618 views
    • 1 reply
    • 1,466 views
    • 0 replies
    • 1,242 views
    • 0 replies
    • 2,161 views
    • 1 reply
    • 5,726 views
    • 9 replies
    • 1,873 views
  9. Terminal board 2000 xplorer

    • 1 reply
    • 1,124 views
    • 4 replies
    • 6,081 views
    • 34 replies
    • 21,729 views
    • 2 replies
    • 272 views
    • 2 replies
    • 1,326 views


  • Latest Forum Posts

    • Bid was $3750.  $4548 with all the fees.  Hoping to see low mileage when I get the power going.  According to the title, it was originally titled 8/2018.  There is about $800 worth of accessories on it too.  Came with no key so I got a $10 chinese replacement just to get working on it. Auction link: www.copart.com/lot/49761799 I wanna pull the clutch cover off too and see how bad it is in there.  I'm assuming its a belt drive.  I charged the battery and its been holding at 12.2v for 2 days(not connected) so Ill see how that goes later.  Would like to get a sealed AGM battery if they're available.  A buddy of mine said to drain everything from the engine, pour a little oil in the spark plug hole and manually turn the crank to lube the cylinder or the walls may get scratched up and lead to major blow-by.  I heard it is ok to use 5W-40 oil in it so I will run a few oil changes through it with that before switching to the pricy polaris PS-4 oil.  My buddy recommended like a half dozen oil changes to get everything out. Unfortunately its at my brother's house about an hour away cause I don't have room for it here.  But it is in a heated garage which helps alot being in the Poconos in December.  
    • Both of those covers look great! Especially for the price.  I would never think of road salt being an issue. Crazy the things we learn everyday.  
    • Excellent advice by @Ajmboy !  I would pull all the plugs apart, fuses out and spray all electric plugs and the fuse box with dialectral grease. Label everything so you don't get confused as well as a few pics incase.   
    • How much did you get it for? I think you are on the right track... Remove spark plug and crank the engine to make sure no water is in the cylinder/hydro locked. Is it belt drive? There should be a drain to let water out. Check all the electrical, buy a new battery because its probably shorted. Change the oil and filter and plan to do it again after you get it running. You may have other electrical issues but you wont know until you try to get it running.
    • I'm using a quadboss atv cover currently and its pretty good.   But if it tears or get another one, I've been looking at this one on Amazon for $27 and has pretty good reviews.  

×
×
  • Create New...