Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

stevebula

Baja 250 wilderness no neutral light

Recommended Posts

Hello,

i have a baja 250u wilderness

and the neutral light wont come on

hence i cant start it unless i pull start it

any input would be great

thanks

the quad is in neutral and rolls just no light and no start

thanks again

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JacobSlabach
      I have a gentleman that asked me to service his bayou for him.  I have always wondered what oil should be used in atv engines?  Pros?  Cons?  What weight should be used in what type of weather?  Is there one kind that I could bulk buy and safely used in any quad I worked on or owned?  What about performance?  Engine Life?  This has always been a 🤔🤔🤔 area for me with quads as far as why you would use one type of oil over another....
      Thanks!
    • By Steven Urban
      First time using this forum.  Owned a Kawasaki dirt bike once, had no issues.  But I picked up this 4 wheeler at an auction.  They stated it ran, but only needed a battery.  Well I do not believe that was all true.

      Some pictures are attached.  Not sure why, but the whole air filter stuff was removed.  They had some small thing inserted as a make shift air filter.

      I purchased a battery to try this all out.  Waiting to return it and get the proper size, as it was too big for the battery box.  But here is my issue I had while the battery was connected.

      1 - The lights on the steering column did not come on.  Not sure if they work or not.

      2 - The starter solenoid seems to be bad.  I have a new one on order. 

      3 - In the pick, there is another rusted part.  Not sure what that part is or what it is used for.

      4 - What is the 12v rectifier?  square bodied part.

      So when I hooked the battery up.  Pushing the start button did nothing.  Pulling the cord to try and pull start, it turned, but would never fire.  I have put in a new spark plug as well, it looked worn out.  With electric start, I crossed over the posts on the start solenoid, it turned over, but would never fire and start.

      I have read a few other threads and it stated something about needed the neutral light on.  SOmething about a kill switch.

      Any help would be appreciated.



    • By JacobSlabach
      i know this isnt an atv but same type of thing.  I have a riding mower im fixing and selling for my aunt and it has a dead battery.  i jumped it off my atv and when i turn the key nothing at all happens.  i tried jumping the relay still nothing.  this is with the seat down.  you wouldnt think this mower would have issues as its a top-of-the-line brand and almost brand new (aunt found it for a good price, still got tits on tires, just sat for a couple months in a mechanic shop
    • By Dwight Williams
      Ok, so I bought this scream of a deal the other day - a 94 King Quad 300 for $40.00.  It's been sitting outside with no carburetor on it for about a year.  Its rusty, missing some parts, wiring is all cut up and spliced etc.  No seat, no racks but the plastic is all there minus the headlight housing.  Anyway, who can pass up a $40.00 quad right?  I get it home and looked at the sight glass for oil level, it's about 1/2 oil and 1/2 water.  I drain it, refill it and turn the motor by hand (recoil starter is missing) and it turns over just fine.  I worked on the wiring for about an hour and got it to turn over with the electric starter and got enough of it sorted out to get a spark.  Did a quick compression test, 70 lbs.  Wet test bumped it up to 90.  Ok, so rings and cylinder washed out with water for a year, not too surprised.  I thought 'what the hell' and sprayed some starting fluid in it and it ran for about 2 seconds - enough to show  it's got life.  Since then the compression has gotten worse, I can't get enough pressure to activate the carb diaphragm, therefore no fuel pump either.  The compression is now around 60.
        Anyway, my question is....is it worth it to try to get this thing going?  I tore the top end down today and the cam and one of the rockers is pretty worn.  I figured a top end job would be about $100 or so, depending on the condition of the cylinder but I'll probably have to put a cam and rockers in it as well.  Doing some research on ebay I figure I'll have to spend about $500-$700 to make the whole machine right again.  Much less just to make it run and use as-is but I won't really like it until it's right.  I don't mind doing the work, I actually enjoy it but I'm concerned about what all that water did to the rest of the internals, I can't really test it all out until I can make it run.
      I know it's a basket case but I'm not into it much at all, even if I do the top end and find something else wrong I'm still not out much.  I'm leaning toward ordering the top end parts and going from there unless you can convince me otherwise - any way to check the rest of the internals without tearing it down?  I plan on flushing the oil cooler before I do another oil change, I've drained it twice now and it gets milky almost immediately just turning the starter - I suspect the oil cooler is polluted badly.
       
      I'll get some pictures today if anyone want to see them.
       
      thanks!
  • Similar Tagged Content

    • By Ellery Zandt
      Does anyone have a redcat 250 or falcon 250cc that they can share where the two vacuum lines on the carburetor that you run antifreeze through I honestly have no idea where the lines are suppose to go to circulate the antifreeze. 
       
      Any help is greatly appreciated. 
       
    • By BosoxBruce
      Recently I noticed gas leaking from under the gas tank on my 2005 250 2x4. As I looked closer it appears to be leaking from the shut off valve under the tank. It's the valve with the handle that can be turned to open, close or reserve. Can this part be replaced? Thank you.
    • By Derick Joel Smith Trimmings
      Buying a Baja 250 tomorrow for 600 bucks, needs nothing but a wheel bearing, i already know Baja is an off brand crappier. Manufacturer, but does anyone have any tips or knowledge of these bikes? 
    • By fatfarmboy
      Just bought (Tue. evening) an '89 Suzuki 250 4wd that has been sitting out the last 5 yrs. It's complete, including the shift knobs, battery cover, and headlights. It has the optional cooling fan on it (probly stuck - didn't check), and the engine isn't locked up. Plastic looks good and isnt cracked. Racks aren't bent up. Shift lever works, the foot brake moves (needs oil - have to pull it up by hand), and there's black oil and no water in the engine sight glass. Guy was asking $125 and gladly took $100 for it. Anxious to get started on bringing it back to life. Been wanting one of these for years. As soon as I can get to it (working on a junky "Jackel" right now - Chinese Yamaha Timberwolf). I'm going to pull the tank off it and clean it, clean & possibly rebuild carb, put in new plug, and a battery, then see what happens. If nothing, will keep going until it runs. Feel free to respond if you want to, I'm mainly just excited and wanted to tell somebody. 
    • By Flanstone
      I just bought two 1985 TRX250's from my father-in-law. One runs great, the other not so much. The one is having issues with the shifter. The shifter seems to be resting lower than normal. When I press the shifter downward, it just pops back up. Any thougjts as to what the issue might be?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...