Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

jandjstark

1998 Suzuki King Quad 300 runs rough when wet underneath

Recommended Posts

I have a 1998 Suzuki King Quad 300 that runs rough when I'm pushing wet snow, or when I drive through taller wet grass. Can anyone suggest what might be exposed in the undercarriage that should affect how the King Quad runs when it gets wet?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Andrew Baker
      I need help with wiring on a 1998 (I think, 10th digit of the VIN was W) Bayou. I'm not getting spark, I'm pretty sure it is due to grounds being off because the harness is pretty hacked as far as the electric start and charging system goes. I'm needing a good wiring schematic. I found one online and there are a few things that don't add up on it so I'm skeptical that it is really for my year and model. Any help would be appreciated. Thanks. 
       
    • By Frank Angerano
      So i took a road trip today to look at a Suzuki Eiger! 2006 in perfect condition other then the fact it starts for 30 seconds and shuts down.  
      Its been sitting for about a year in a shed. 
      It has a plow and a winch included!!!
      Got it for a really good price and all looks good so far.  
       
      Stay tuned.  





    • By MarkinAR
      And the new 300FW is already wounded. Something got in a bind and blew the whole chunk of case out around the primary drive gear at the back of the motor. In the pic you can see the crack along the top...there is a big chunk missing from the bottom. And it won't roll....but the front and rear diffs both seem fine. Unfortunate. This looks to be a bit of a project. Still feels like it will shift through gears so i'm wondering if the ring and pinion just jumped a bit and blew something to pieces.  I have a parts bike.  But will this require the case to be split and transmission completely disassembled?  I assume you can't just slide the broken primary drive out and slide the replacement in?
       

    • By Randel1
      I am trying to put a 1994 Suzuki 250 quadrunner back into service. I have it up and running like new but need to replace the plastics as they are brittle and crumbling due to age and sun exposure. I would like to purchase new parts either OEM or aftermarket but have had little luck in finding them. I would even consider used or salvaged parts in serviceable condition. Any help in locating these parts would be greatly appreciated. Thanks in advance.
    • By Gunny
      So, what did you do on tax day ?? Me, I went for a track ride even thou it was foggy and snowy ...   Hope you enjoy the winter time video ...             ...
  • Similar Tagged Content

    • By weblex
      Problem: The ATV starts and runs at idle perfectly. But as soon as I open the throttle, the engine starts to slow down until it stops. On the attached video you can hear the sound of how it works: see video below
      Prehistory: there is a Polaris Sportsman 500 1998, which for about 1.5 years stood in repair, including also replacing CDI with one taken from the same ATV. Finally, the vehicles were on wheels, traveled several kilometers and overheated - forgot to fill the antifreeze Came back home in small moves. The next trip started well, but after 10 km there was a feeling of a small drop in power (even as the vehicle got warm completely) but still drives. Next trip - the situation is repeated. The next test of ATV through time and a huge loss of power from the very beginning. The engine sneezes, does not want to go more than 5 mph.

      What has been done: the carburetor has been replaced with a new one (inexpensive, $ 40), a new spark plug, a new ignition coil, the engine head has been removed, the piston is in good condition, valves were corrected - but the problem was definitely not in them.

      Ignition control unit is suspected. Who faced similar? Please help in solving the problem.
      Thanks in advance.
       
       
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...