Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

evlsnke

lt80 suzuki

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By My kiwi shed
      Hi there everyone. Just seeing if there is advice on a problem I have before I start digging too deep. 
      I recently bought this creally nice 2004 King quad ltf300 with only 2400km..
      Everything things works great except when engaged into 4wd or diff lock it has a clicking noise ( sounds like broken teeth etc) are the front diffs known to blow?  Or the transfer from engine?
      I am yet to test on some loose ground to see if I'm getting drive at front .
      I will be driving in to find problem in next few weeks but thought I'd see if anyone might know what it is first. Cheers


    • By Chase Cook
      I have a 2001 yamaha yfm350x and it has a brand new top end, new carburetor (stopped the leaking problem and is now getting gas to it), new CDI box, new stator, handlebar switches work, off-and-on switch works, new starter solenoid (works), new neutral relay (works), ordered a new Rectifier on its way, good strong blue spark. Has compression, valves are right. Timings is right and is TDC. When I try to start it it just makes a loud popping noise like its backfiring but it's not because its not running when I push the throttle all the way and when i barly push the throttle it try to start but won't, so I'm trying to figure out what could be the problem not starting now, Getting very fustrated with this thing and put some work and money into it and it's not still not working. This is the only atv I ever had that I can not figure out the problem to get running. Need help please..
    • By Chase Cook
      I have a 2001 yamaha warrior YFM350x and started to work on it. The person who I got it from put a new top end kit in it. I already took the top end off and checked, brand new still. Had to clean the valves so it can get better compression. Put it back together and turned it over and and made good compression but also had a loud clanking noise at the bottom, put hand over carb and stopped making the noise when I turned it over. And won't start.  I know it is not the top end. Just cleaned it and valves. Need help trying to figure out what's the problem.. thinking it's the crank rod but don't know. If it is the rod can i just get a new rod for it?(would be great if so). Or does it need a hole bottom end . In need of help.
    • By dirtjunkie85
      I have a 2008 Teryx and it has been great the only complaint I have is the engine or transmission noise inside the cab, it is a loud wine and has been this way ever sense I bought it any suggestions or products that may help quite this noise down a little??
    • By Wolds Alpacas
      I have a Yamaha YFM225 which sounds really noisy exhaust wise.  It had no baffle so I bought and installed that but it seemed to make no difference.  There are no leaks from the manifold or exhaust but the damm thing just sounds  so loud !
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...