Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Arekp

Kymco mongosse 90

Recommended Posts

Ho need help I have a kymco mongosse 90cc 2004 I put new carb on Everything work perfect except when i start and automatic choke is on engine working when choke shot down engine stop I have to start motor and hold little throttle ones heat up little working perfect??????

Share this post


Link to post
Share on other sites


Who you calling a ho??? LMAO...

Get a manual choke carb.The elec choke carbs have so much trouble

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By domesticated
      So we bought three Kymco quads spring of 2017 and put them through the test all summer in north central WA mountains.  My boys MXU 270 surprised the hell out me several times when I thought for sure id have to pull it through some muddy spots but he cruised on though like it was 4 wheel drive(which it isn't).  Really a well built great beginner quad even for younger riders as it comes with the restrictor rings that only allow for about 25mph till they are ready for higher speeds which this tops out at about 45mph which is plenty for mountain trails.  
      The wife's MXU450i is about the smoothest running, and shifting quad I have ever been on.   Has great pep for a 450 and with on the fly 4x4 she has gotten up every where I've gone(despite my best efforts).  She is only 5' tall and really likes the narrower seat on the 450, something to keep in mind if your considering a 500 as that will put you on the wider body which may not be as comfortable a ride for some.
      I really have only have one complaint about my 700i and that it isn't a 1000 .  Super comfortable to ride and plenty of power.  Rode these all season with no issues what so ever.  To be honest the quality of these machines is definitely comparable to Yamaha, Suzuki, or Arcticat.  The main reason I bought these was the price.  I was able to score all three for about $14,500 after tax as the dealer had been sitting on them for about a year since no one around here wanted to take a chance on an unknown brand which worked out very well for me.  The mxu270 came with decent undercarriage guards and plates but the skid plates on the 450 and 700 are plastic so defiantly replace if your riding in rocky areas.  I made mine out of 3/16'' aluminum using the plastic plates that came on them as a template.  Only took about $100 and a weekend but you can also buy these if your not a cheap as I am.




    • By amharrison24
      i have a 91 moto 4 100. has electric start only. for as long as i could remember we have always pushed start it. after riding for while you shut it off. you are able to hit the start button and it will start right up. anyone know where i should start with fixing this issue? im fixing it up for my niece. thank you in advance.
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Steven Urban
      First time using this forum.  Owned a Kawasaki dirt bike once, had no issues.  But I picked up this 4 wheeler at an auction.  They stated it ran, but only needed a battery.  Well I do not believe that was all true.

      Some pictures are attached.  Not sure why, but the whole air filter stuff was removed.  They had some small thing inserted as a make shift air filter.

      I purchased a battery to try this all out.  Waiting to return it and get the proper size, as it was too big for the battery box.  But here is my issue I had while the battery was connected.

      1 - The lights on the steering column did not come on.  Not sure if they work or not.

      2 - The starter solenoid seems to be bad.  I have a new one on order. 

      3 - In the pick, there is another rusted part.  Not sure what that part is or what it is used for.

      4 - What is the 12v rectifier?  square bodied part.

      So when I hooked the battery up.  Pushing the start button did nothing.  Pulling the cord to try and pull start, it turned, but would never fire.  I have put in a new spark plug as well, it looked worn out.  With electric start, I crossed over the posts on the start solenoid, it turned over, but would never fire and start.

      I have read a few other threads and it stated something about needed the neutral light on.  SOmething about a kill switch.

      Any help would be appreciated.



  • Similar Tagged Content

    • By Ed Maki
      I have a 2004 kymco mongoose 50 two stroke and it was a mess and it didnt run when I got it. There was practically no wiring harness and all of the wires that were there were electrical taped together. Long story short I ordered a aftermarket wiring harness (Complete Wiring Harness Electrics Wire Loom Kit CDI Rectifier Ignition Coil Magneto Stator For GY6) installed it and now I have no spark. Any ideas or help would be greatly appreciated.
    • By Awakzrx
      View File KYMCO MXU 500 IRS Service Manual
      i hope that someone is happy with the file for KYMCO MXU 500 IRS Service Manual
      and greeting from Belgium
      Submitter Awakzrx Submitted 10/31/2018 Category Kymco ATV  
    • By Awakzrx
      i hope that someone is happy with the file for KYMCO MXU 500 IRS Service Manual
      and greeting from Belgium
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...