Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Gadget44

predator 90 carb

Recommended Posts

got it running new cdi coil and stator will idle good but when u give it throttle it will take off but then will bog down but if you put it on jack stand in the rear it will rev up good with the tires spinning only bogs under load have removed carb and cleaned did find that the pilot jet was clogged and cleaned it main jet is clear and open any ideas

Share this post


Link to post
Share on other sites


compassion is almost 120psi clutches seem fine it will go if you are the throttle till bout 1/2 throttle but if you try to give it any more it will bog down but you let off for a sec then go again to me its like it don't have enough fuel in the bowl to supply wot it has a plastic float in it

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By technofarmer
      Hi there i was needing to ask a question. I may soon be getting a UTV of one sort or another and not sure what is good or better to avoid?  So far i hear great things about the Arctic Cat Prowler and Havoc, and many speak well of the Kawasaki Mule all but the 610?  
       
       So what are your thoughts and especially experiences?  What have you had and used in farm life and trail riding that has held up well or hasn't?        
    • By marek porowski
      It’s kind of ATV related question as I need new trailer tires to tow my 4 wheeler. 
      Does anybody have any experience with loadstar 12” trailer tires ? 
      There is not to many choices for trailer tires here in Ontario and I was wandering if somebody can recommend me something. 
    • By Jeff Comstock
      Ok, so I had no spark issues and foundy coil was bad. Bought a caltric coil, put it on and fired right up...for bout 20 minutes then it backfired once and again, no spark. I put it on my buddies 300 and it runs.  Checked my cdi the same thing, but still no spark. Now I got my old coil and  was ohming it and got reading of .01 on primary and 11.89 from POS to plug ( meter set on 20k ) new coil reads same primary but 12.83. what gives? It tests bad but runs my buddies 300, helllllllpppp
    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
    • By Bruce Madsen
      My 1999 Artic Cat 500 ATV has started bogging down and backfires shortly after starting.  Any suggestion for a remedy?
  • Similar Tagged Content

    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By Tubecatgs
      A friend of mine has this Bayou 220 that started running bad and parked it a few years ago. I foolishly volunteered to take a look at it. I noticed right away the choke plunger on the carb was broken and probably the reason it was running bad but now the old gas was evaporated and like turpentine. Before i even tried to start it, i drained/ thoroughly washed the tank out, new fuel filter, new fuel lines. Blew air through the petcock etc. Changed the oil and filter and air filter and new choke plunger and cable. I disassembled the carb and rebuilt it with a kit. I cleaned the main jet with solvent and poked a wire through it to make sure it is clean.. the engine now fires right up with the choke on and dies when i take the choke off. I adjusted the air/fuel screw to about 1.5 turns out and the idle screw about 2.5 turns out. The rubber boot between the carb and head does not have any cracks in it so I don't think it is leaking air. I originally had the clip on the needle on the second from the top ring... when i moved it all the way to the bottom it starts, runs and idles really fast and will idle eeally high with the choke off but if i adjust the throttle cable and/or idle screw to a slower idle it will sometimes stall but the idle will go up and down every few seconds and when you give it gas there is a hesitation... i tried moving the clip down to rhe second from bottom and same problem... i replaced all the parts in the pic to the top right. However, there appears to be a small o ring, washer and spring left over from the kit... i did not see these get removed..... a) any idea if where these extra parts go and if i need them and b) any other ideas on why i cant get it to idle right or carb adjustment ideas?
      Thanks
    • By bradley nelson
      What is the best and easiest way to tune your carburetor? Any tips or tricks?
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...