Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

buzzar56

polaris sportsman 500 ho atv

Recommended Posts

I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace

thanks fred.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By dany desbiens
      Hello i have a Polaris 2003 sportsman 600 Polaris Sportsman OEM Gauge Speedo Speedometer Display Dash Cluster 3280425 the speedo is not working no 4*4 i can find nothing can i put a speedo 2004Speedometer Gauge Speedo
      3280431 04-08 Sportsman if it will work
    • By Arizona
      So few months ago I acquired a 01 Explorer 4x4 (think its a 350 but not sure) 
      Anyway the owner said it started reving very high, shut the key off and still kept running 
      until finally he shut off fuel and it finally died. During the run away he said the exhaust got 
      red hot and has melted plastics to prove it. Said some thing flew out the tail pipe, I kinda figured
      it was the top of the piston. Anyway finally got around to looking at it (have a lot of other projects in the works)
      and checked the compression, Shows about 40 psi. Can hear air coming out the carb while rotating the motor over. 
      Gonna pull it apart eventually, don't hear any noises or binding in the stroke, You think the piston came apart? 
      any horror stories of these and is it worth my effort and money? Don't really have any money in it yet. Thoughts? Az


    • By Venom
      Hi All,
      I did a total restoration on a 2003 Yamaha Raptor 80. Rebuilt the engine and tranny.. Started it up today and it runs great. Took it for a ride and the transmission worked perfectly. Adjusted the carb a little more and went for another ride. It ran awesome, pulled into the workshop shifted into neutral ( Neutral light came on) and shut off the bike. went to roll it and noticed she would not roll. Turned on the key and neutral light was on... After some troubleshooting I found that she is in first gear with the neutral light on and will not shift into neutral... It seems to up shift fine into 2nd and 3rd and then back down to 1st. I am hoping somebody can shed some light on what is happening... Thanks for any help...

    • By Venom
      Hi, All

      I started this project a while ago.. I have decided to make one thread I can continuously update..

      So , here we go. I got this Raptor 80 in really bad condition.. Rear end frozen, Engine toast, tires dry rotted, tons of rust..etc.. They admitted they beat on it very hard.

      Since they do not make these with a drive shaft anymore I decided to restore it from top to bottom..

      These are photos of when I got it home.

      Next up, the tear down..



      First, I needed to tear it down and determine if the rear end was still good... As we all know... That is where it would be cost prohibitive to restore if it is trashed..

      Got it completely stripped down and I lucked out... The rear Drum brake was caked solid inside with dried mud. That was causing the rear end to lock up. Took off the rear brakes and the rear end spun perfectly smooth.

      Once I got it all stripped apart I needed to take the finish off all the parts. I am going to be powder coating the frame and many parts.. Once the finish is off each part it will need to be sandblasted to white metal .. The guy I use for powder coating gives me a hefty discount if I bring the parts to him ready to go.

      You could just sand blast, but that would take a long time to get the finish off. First I used Aircraft Paint Remover.. That stuff is pretty toxic Goggles and Resperator are required. That quickly gets you down to the metal... Then you can sand blast to white metal pretty quickly...


      I had another thread I had started about a problem with the tear down... It has some great info .... here is the link... It is about removing the frame bushings. ....
       
      https://www.quadcrazy.com/atvforum/topic/14209-raptor-80-frame-bushings/?tab=comments#comment-104702
    • By bodon
      I have a 2011 850 Sportsman.  Has been absolutely trouble free except for 1 thing. I am on my 4th. ignition switch. I don't know if it's that they are all chinese junk or what.  It gets to a point  when you turn the key and it will act like the battery is going bad. Cranks real slow or not at all. Put a new switch in and its fine. New one will last 1 1/2 - 2 years and its junk. I've had the Polaris brand and after market. As a matter of fact the original one lasted the lest amount of time.  Other than that it's been a perfect machine . No electrical problems. No battery problems. Just curious if anyone else has had the same issue.
  • Similar Tagged Content

    • By Alois Specht
      Hi there , have a KAZUMA 500 JAGUAR the rear diff is permanently locked , how can I get it out of lock just about tried everything I think, ?? .  Thank you your help is appreciated.
       
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • Guest Fox300exchic
      By Guest Fox300exchic
      Indicators that tell you to check your toe-in.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...