Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

crazynordlander

CFORCE 500 HO EPS low speed drivability issue

Recommended Posts

Hi All,

I live in Minnesota and bought a 2016 CFORCE 500 HO. I am in hope to see if there is anyone in the US that is experiencing this sudden drop off in RPM below 4000 RPM. I have uploaded some videos of my issue on YouTube. I will list three of the four I posted. The fourth can be found on my channel but it is a comparison between my Polaris 570 and my CFORCE 500.

I quit on my first dealer because we just did not mix well together. I brought it to another CFMOTO dealer that just became a CFMOTO dealer in January 2016. They are in a large ranch and agriculture area in a neighboring state that is pretty close to where I live. They have close to every brand available. They are a much larger dealer than the first one I bought the unit from.

I brought the unit three weeks ago to them and they have worked on it a good solid week and have given up on it. I have read reports from owners in Canada that the dealers there were aware of the issue and have had success in fixing the herky jerky drivability issue.

I am picking it up tomorrow and bringing it back home. It has been to the trails of the Black Hills this year and was new in late April. 300 miles on it. It has never changed. Very hard to ride on the trails or when I herd livestock.

Here are the links to my videos.

I can't accept that this is normal operation. Does anyone from CFMOTO China scan these posts?

I need help that CFMOTO USA has not provided.

Thanks

Kevin

Edited by crazynordlander

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By domesticated
      So we bought three Kymco quads spring of 2017 and put them through the test all summer in north central WA mountains.  My boys MXU 270 surprised the hell out me several times when I thought for sure id have to pull it through some muddy spots but he cruised on though like it was 4 wheel drive(which it isn't).  Really a well built great beginner quad even for younger riders as it comes with the restrictor rings that only allow for about 25mph till they are ready for higher speeds which this tops out at about 45mph which is plenty for mountain trails.  
      The wife's MXU450i is about the smoothest running, and shifting quad I have ever been on.   Has great pep for a 450 and with on the fly 4x4 she has gotten up every where I've gone(despite my best efforts).  She is only 5' tall and really likes the narrower seat on the 450, something to keep in mind if your considering a 500 as that will put you on the wider body which may not be as comfortable a ride for some.
      I really have only have one complaint about my 700i and that it isn't a 1000 .  Super comfortable to ride and plenty of power.  Rode these all season with no issues what so ever.  To be honest the quality of these machines is definitely comparable to Yamaha, Suzuki, or Arcticat.  The main reason I bought these was the price.  I was able to score all three for about $14,500 after tax as the dealer had been sitting on them for about a year since no one around here wanted to take a chance on an unknown brand which worked out very well for me.  The mxu270 came with decent undercarriage guards and plates but the skid plates on the 450 and 700 are plastic so defiantly replace if your riding in rocky areas.  I made mine out of 3/16'' aluminum using the plastic plates that came on them as a template.  Only took about $100 and a weekend but you can also buy these if your not a cheap as I am.




    • By bradleyheathhays
      Just now rolling over 100k miles. Been feeling some steering weirdness so I get one front wheel up in the air and push at 3 and 9 and sure enough there's some wobble. Pushing at 12 and 6 gives no play at all.
      Although I'll probably be replacing the worn part myself I need some help diagnosing what all might need to be replaced. And since I need an alignment anyway I've made a deal w/ my local Goodyear tire shop to do a pre alignment inspection and identify my bad part(s) so I can replace them before they do the job.
      When I drop the car off what specific parts should I ask them to look at? I'm sure tie rod ends but what other kind of worn parts could be causing movement on the 3-9 push test?
    • By amharrison24
      i have a 91 moto 4 100. has electric start only. for as long as i could remember we have always pushed start it. after riding for while you shut it off. you are able to hit the start button and it will start right up. anyone know where i should start with fixing this issue? im fixing it up for my niece. thank you in advance.
    • By Matt John
      Charging issue?
      I have a 2017 Polaris Sportsman 570 EFI. Yesterday, I start the machine and it says low power (10.6-10.8). This machine is on its second battery. This is a new AGM battery with 50cca more than stock.
      Should I look at the regulator or stator?
      Thanks!!!
  • Similar Tagged Content

    • By Alois Specht
      Hi there , have a KAZUMA 500 JAGUAR the rear diff is permanently locked , how can I get it out of lock just about tried everything I think, ?? .  Thank you your help is appreciated.
       
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...