Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



What's up stranger! That's a great find and looks like its in great shape also. I remember you had a bunch of three wheelers and if I remember correctly, you also had a CAN AM spyder, right?

Share this post


Link to post
Share on other sites

What up Brotha Man!!! Yes I had LOTS of trikes. I currently only have two and that's probably the way it will stay. My youngest is into cars and girls now. He still loves to ride but the little 70s he found out are just a little too small...LMAO!!! He is 6'2 and will be 15 in two months..He rode the Hell out of that 125 for 7 days..I still have a 08 Raptor 700R SE that I bought new. I hate that thing. Its been parked since 09. It has less than 10 hrs on it. He wants that now.. The wife and I have the RZR and love it.  Still have my Tri-Z too..  Got rid of the spyder in 09..They bought it back. Too many problems..I commute on my Motorcycle now.. 

Share this post


Link to post
Share on other sites

You must be a proud papa! Glad to hear you are doing good. I have two daughters, 8 and 2 and both look to be going into mom's way of "fashionista" and less of outdoors and atvs...lol. There's still time! Was thinking of picking up a small quad for my oldest. I have an 04 Grizzly 660 currently, use it mostly for plowing and around the yard, once in a while do a little riding. Need to do more! I'd love to get an RZR, post some pics when you get a chance. 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By cliffyh
      Hi,
      Have a 2005 grizzly 660. Just recently started backfiring and showing incorrect speed. Lifted seat and messed with wire going to starter relay, it stops for a bit but seems to come back.
      I ended up pulling all the pins out of the connector for the relay and added new pin/connectors for all 4 wires. fixed it for a little bit but came back shortly after. This was a new starter relay i installed a few months ago. Anyone know if a bad starter relay would do this? 
    • By Dale Kermes
      I need some help y’all, I bought a 450r, 2005 and I was riding it and unfortunately got stuck, I had no clutch control at all, I put it in gear and release the clutch, it doesn’t go anywhere, I select through all gears and it won’t move, i can rev it out, I just bought a clutch kit, but I am sorta new to this whole scene of race quads, I always had a 4x4, so any help will be much appreciated thanks.
    • By Ssg
      Hello! This is my first bike with a cvt it's a 19 Outlander 850 xmr. I use the 30" cryptid tires that come with the bike during hunting season since I hunt in a louisiana swamp and I have some 27" interco reptiles during the summer trail rides. So this past hunting season I got stuck and squealed the belt do i looking at cluch kits /adjustments to help with the low end but I dont want to mess with my summer riding so I'm looking for advice 
    • By Adrian Ciotinga
      So I’ve had this quad for the better part of a month, and it’s been hard to start since the day I bought it. Once it warms up it idles just fine and has plenty of power and starts no problem, but cold it takes 20 seconds minimum of straight cranking to start it.
      It’s not really too big of an issue, I’m just curious as to why it takes so long. Earlier today, it took me about 2 minutes of on/off cranking to get it to fire.
      i have attached a video of a cold start to show you what I mean.
      FullSizeRender.mov
    • By Bruce Sawyer
      1987 YFM350FWTB 350 4x4 Big Bear when going uphill will sometimes act like the clutch realeases then re-engauge all at once.
      Seems to maybe be little more often if the engine is at about 1/2 throttle instead of at lower rpms.
      I have the Factory Service manual and checked the external clutch adjustment screw as ok and the H/L/reverse shifter lever linkage as adjusted correctly. It appears to be maybe a internal (inside the case) clutch issue or ??
      This is the type Big Bear that has the manual shift lever on the left front fender and has the manual foot shifter lever with 5 speeds forward.
      Can someone tell me how the primary and secondary clutch operates? 
      I assume one is mechanical and one is centrifugal. (what I'm asking is one clutch for the higher rpms and one for the lower rpms or ???. (the clutch appears to only momentarily release at the higher rpms is why I ask. The cycle has about 3000 miles of low speed through the brush hunting and has been well maintained, oil changed, etc and no deep water or mud useage.
      Anyone been into a similar issue with the big Bear ATV????
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...