Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Travo

1992 Suzuki LT 250 4wd carb hose routing

Recommended Posts

 

Can anyone help with routing the hoses on a lt250 carb hose routing? Manual doesn't really specify much, and pictures are lacking in it

Sent from my XT1585 using Tapatalk

 

Share this post


Link to post
Share on other sites


It's a 1992 Lt 250 4wd. I believe it's a mikuni 34 flat side. Just looking to find where exactly the hoses go.

Sent from my XT1585 using Tapatalk

Share this post


Link to post
Share on other sites

Hi Travo, I moved you topic to the Suzuki Forum and edited your title to include what you added in your second post. I'm not familiar with that setup, but hopefully someone in the community can lend a hand.

Share this post


Link to post
Share on other sites
Hi Travo, I moved you topic to the Suzuki Forum and edited your title to include what you added in your second post. I'm not familiar with that setup, but hopefully someone in the community can lend a hand.

Hey thanks!

Sent from my XT1585 using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Sonders
      It appears that the Service Manual thread at top of forum is dead as all the links no longer work.  I'm actually looking for service manual for a 2000 KVF300 Prairie that I just picked up.  Does anybody have link to one that they can share, or know where I can find one?  Thanks in advance for any help.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By 87tecate4
      View File 1999-2002 Honda TRX400EX Service Repair Manual
      1999-2002 Honda TRX400EX Service Repair Manual
      Submitter 87tecate4 Submitted 07/18/2018 Category Honda ATV  
    • By 87tecate4
      View File Lakota KEF-300 Service Manual 1995-2004
      Kawasaki Lakota 1994-2004 Service Manual
      Submitter 87tecate4 Submitted 07/10/2018 Category Kawasaki ATV  
  • Similar Tagged Content

    • By BosoxBruce
      Recently I noticed gas leaking from under the gas tank on my 2005 250 2x4. As I looked closer it appears to be leaking from the shut off valve under the tank. It's the valve with the handle that can be turned to open, close or reserve. Can this part be replaced? Thank you.
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By Jason Magnone
      As stated above working on a 1999 Suzuki LT-F160. I think I’m having trouble with the carburetor. I keep fouling spark plugs. Full disclosure, I did make a poor attempt to “rebuild” the carb (that’s why I think that’s the issue). No idea if the new parts are at the correct “settings” (gaps and such) I believe the starting point is 1.5 turns from bottom out on the adjustment screw (is there another adjustment I don’t know of?).  Doesn’t feel like I’m getting gas drawn through the carb (clogged jet maybe?), the plug isn’t wet at all (assuming why they’re fouling?) Not a great deal of experience working on carbs and not having much luck on finding a lot of info on the 160’s.
      1st- by chance can I swap out the original carb (13200-02C03) for an LT 250 model (think the HA01050). They’re only about $30 apposed to $200. That would at least narrow down if it’s a wiring problem or carb issue.
      2nd - The wiring has been minipulated at least a dozen times (before I acquired it, my cousin got it from a buddy kind of thing). Hopefully don’t have to dig into this too much as it’s currently a bit if a mess. 
      I was told it ran last year... 
      Any imput would be greatly appreciated
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...