Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
ATVNetwork

Gee Armstrong’s YFZ450 Drag Racer

Recommended Posts

gee88.2016.nwbest.june10.8.jpg?itok=Gz7OqIDk

Build Sheet

If you have raced or just watched the races in Albany Oregon lately, you have seen Gee’s bright green and white Yamaha YFZ. For those who haven’t, we have it for you…

View the full article

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Coyote251
      View File 2000 Yamaha Big Bear YFM400 Owners Manual
      This manual contains all information for owners of this vehicle including operational directions, safety and maintenance procedures
      Submitter Coyote251 Submitted 03/22/2018 Category Yamaha ATV  
    • By AFricks88
      It will not turn over with starter and will not fire while pulling pull start.
       
      The only thing that Ive tested that didnt test correct is the kill switch I read on another forum to test black and Black/white wire for continuity when in off position I did and it shows continuity like it should. Then when you slide it to run it should be open and show no continuity which mine still shows it while in the run position. So I unplugged the CDI just for sakes of doing it and the kill switch then tests correct. So where should I test next without unplugging CDI?
    • By Lellwyn Griffin
      I am looking for pictures of your carburetors, specifically looking for what type and where the hoses go on the red circles.
       
       
      Sent from my iPhone using Tapatalk
    • By Arby911
      I can't for the life of me find the correct service manual for this unit. It's air cooled, not liquid (oil cooler tho) and every manual I find has the wrong front differential diagram (it does NOT have a 2wd/4wd shifter).
      I'd be eternally grateful if someone could point me in the right direction. I can probably slog it out from some of the exploded diagrams I've found, but a good "do this, do NOT do that" manual would be a godsend.
      Regards,
      Ross
    • By Wesley Floyd
      Hey guys, Thanks for looking at my post. I haven't had a lot of experience with problems like this before, so I'm a little bit at a loss. The Quad was really hard to shift, (the dirty carb leaking gas making it idle high didn't help either). The only Idea I have would be is that the torsion spring is worn out, and that there is a normal parameter for how much it should move when those two arms of the shift shaft assembly spread apart.  That's my thought. Maybe someone who has more knowledge then me can let me know if i'm on the right track 😀

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...