Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

giterdone

2007 Bruteforce 750...Help!

Recommended Posts

I had quite the ride the other weekend. I rolled the quad then kind of submerged it. Needless to say I'm having some issues with it now. It idles fine, but when you lower the choke and give it some gas it pops out of the carbuerator and backfires from the exhaust. The carb is clean and the fuel is clean. I also changed the oil and the diff. I changed the spark plugs and checked the CDI box by switching it with a working one. Any other suggestions? Any and all suggestions would be appreciated!!

Share this post


Link to post
Share on other sites



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By mikeexplorer
      Wiring diagram for 2007 Arctic Cat 700 EFI 4x4
       
       
    • By Mikes700efi
      I just bought my first arctic cat. I changed the oil and filter. Now my atv smokes only when u rev the engine. Smoke looks white grey.. slight light blue tint.. when it. Idles it doesn't smoke.. Any body have a clue what is going on. The dealer said it's not the rings.. it has the 700cc suzuki engine..
    • By Mikes700efi
      Can someone tell me how to remove the rear sifferential. I've got the cv axels out. Do I remove the rear shaft. Or do I pull differential off shaft. Noticed the axel shaft leaking where it go's in the engine. .
    • By surbike11
      Thanks in advance for any help or guidance. I was out riding the other day and lost all spark. I have read every thread on every forum that I could find and have not found an answer. I have checked the codes and its 00. I have ohm metered the stator and crank sensor. I have also replaced the coil pack. I have inspected and cleaned all connections. I do not mud the machine, it is mostly used at the hunting lease for working plots. When I installed the new coil I held the plug on the side of the engine and got 2 little sparks when first turning over and then nothing again. When you turn the machine over like this it eventually flashes EFI on the screen. I checked both wires that go to the coil and noticed that both have ground continuity. While turning over the blue and white one cycle from around 1v to almost 12v. The battery has a full charge and I am at a total loss. I took the kill switch apart and all looked well. Oh yea and all fuses are good. Help me please I am getting very frustrated. Thanks
    • By rejeanc
      Hi all,
      looking for 2007 Yamaha YFM450FWAN Service Manual.
      Having problem with rear brake and wanted to fix it, the pedal is stuck.
      Tried all links in forum, but none of them work.
      Thanks to all!
  • Similar Topics

    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By Countryboy57
      Hello I’m new here and I need help finding out what kind of quad I recently got for free. When I looked up the vin all it showed was 2004 and made in China. Any help will greatly appreciated thanks.
       

    • By BuckBilly
      I like to ride in wooded and grassy areas. It takes my mind off the everyday routines and helps me deal with my father's cancer. Also gives me a reason to get involved with forums like this one.
    • By Airborne
      Hows evryone feel about blasting around in snow ? 
      I love it usually after all plowing is done ill drop the plow and just go lut and have fun. From drifting all over lol to packing snow trails in woods its fun , never been into snow mobiles ,  where we live its very rural and our roads seem like an afterthought when it comes to plowing lol , usually last to get cleared , so we will hit the back roads to powerlknes and such , we have several people around here with side by siedes ,and the usually hit the powerlines , pack the trails and then we hit them good fun ....Anybody else ?
    • By Bryson Bailey
      Hey I have a Kawasaki buyou I put a new carburetor on it and a brand new spark plug coil and still firing up could you know what my problem is anyone please
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...