Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

grego86

Help with brakes

Recommended Posts

I have a 1988 Big Bear 350 4x4. I had to take apart my front brake pistons and thoroughly clean them. The internal gaskets appear new from when I had bike shop I thought do a brake repair. Seems like they just replaced gaskets and didn't bother cleaning or clearing any of the trash from system. I put everything back together and try bleeding system and pumping up brakes. The front piston on both sides will just barely build up and it does hold and when I bleed them I get a solid stream of fluid so don't believe there is any blockage. Also to note the bleed valve is after the rear piston on each side so fluid is reaching it but for some reason not building pressure I'm guessing. How can I tell if I need to rebuild my master cylinder ?

 

 

Pic - the piston on left is before and right is after I cleaned one.

atv brake pistons.jpg

Share this post


Link to post
Share on other sites


If there  is no  air in the  system  and no  fluid leaks, then  if you  cannot  build  pressure in the system there is a problem with the  master cylinder bypassing and it needs to be rebuilt.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      Unfortunately this weekend we waived goodbye to the 99 400ex.  Ported and polished head, DMC Alien exhaust with dual header, an absolute unit that would run 70 on the top end.  Fortunately though the 400ex left in exchange for a fairly cherry 98 Honda 300..the holy grail of reliability in a mud and water toy.  Previous owner added the snorkels and it was a decent job.  Put some 25" swamp witches on it, now it just needs 1" spacers, 2" bracket lift, couple of pinion seals and a pound or two of dielectric grease.  Hate to let the 400ex go as it was a gem, but it's hard to pass on a cherry 300.  These things are just so dang reliable and easy to work on.

    • By K L Buck Naff
      Trying to replace the carburetor on my 2003 Bear Tracker 250. Two brand new carbs in a row from different suppliers.   Both leak fuel out over flow and intake as soon as I turn the gas on. Any ideas. Am I doing something wrong?
    • By Hondasher
      I picked up a 1997 Yamaha Big Bear 350 2X4 a week or so back in non running condition, apparently they said it needed a new carburetor or a battery, I cleaned the carburetor thoroughly and got it running on idle and without choke now and it shifts into all the gears even into reverse. Aside from making me bounce a little when trying to start out with a bit of throttle the shock suffice to say needs work. Anyways I made a video of it running and would like your opinions on it, as to how it sounds while running. It seems like it has a little whine I'm not sure why that is maybe someone can tell me what it is. Anyways here is the video.
       
    • By Randel1
      I am trying to put a 1994 Suzuki 250 quadrunner back into service. I have it up and running like new but need to replace the plastics as they are brittle and crumbling due to age and sun exposure. I would like to purchase new parts either OEM or aftermarket but have had little luck in finding them. I would even consider used or salvaged parts in serviceable condition. Any help in locating these parts would be greatly appreciated. Thanks in advance.
    • By Admin
      View File 1987 - 89 Yamaha Big Bear 350 Service Manual
      1987 - 89 Yamaha Big Bear 350 Service Manual
      Submitter Admin Submitted 12/13/2016 Category Yamaha ATV  
  • Similar Tagged Content

    • By Bruce Sawyer
      1987 YFM350FWTB 350 4x4 Big Bear when going uphill will sometimes act like the clutch realeases then re-engauge all at once.
      Seems to maybe be little more often if the engine is at about 1/2 throttle instead of at lower rpms.
      I have the Factory Service manual and checked the external clutch adjustment screw as ok and the H/L/reverse shifter lever linkage as adjusted correctly. It appears to be maybe a internal (inside the case) clutch issue or ??
      This is the type Big Bear that has the manual shift lever on the left front fender and has the manual foot shifter lever with 5 speeds forward.
      Can someone tell me how the primary and secondary clutch operates? 
      I assume one is mechanical and one is centrifugal. (what I'm asking is one clutch for the higher rpms and one for the lower rpms or ???. (the clutch appears to only momentarily release at the higher rpms is why I ask. The cycle has about 3000 miles of low speed through the brush hunting and has been well maintained, oil changed, etc and no deep water or mud useage.
      Anyone been into a similar issue with the big Bear ATV????
    • By Hondasher
      I picked up a 1997 Yamaha Big Bear 350 2X4 a week or so back in non running condition, apparently they said it needed a new carburetor or a battery, I cleaned the carburetor thoroughly and got it running on idle and without choke now and it shifts into all the gears even into reverse. Aside from making me bounce a little when trying to start out with a bit of throttle the shock suffice to say needs work. Anyways I made a video of it running and would like your opinions on it, as to how it sounds while running. It seems like it has a little whine I'm not sure why that is maybe someone can tell me what it is. Anyways here is the video.
       
    • By Gary Ferguson
      My old Big Bear nearly left me stranded but I managed to limp back to my garage just before it died. Now No Spark. I’ve changed the obvious, inexpensive and easy parts- spark plug & coil without any luck. 
      Ive stripped it down and traced all of the related wiring, checking as many connections as I can but no luck again. 
      Next I pulled the cover and accessed the stator housing to inspect and do some resistance testing to ID a possible short. 
      Here are my readings:
      Source coil- 325 ohms
      Pickup coil- 225
      Can anyone tell me if these are good numbers, and if good, where to go next?
      I assume my next purchase will either be a new stator or CDI, but since neither of these tend to be returnable items I want to be as sure as I can I’m gonna get a resolution to the problem!!
      Thanks,
      Gary in SC
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...