Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Ajmboy

2004 Yamaha Grizzly Foot Rest Rusted Broken

Recommended Posts

Unfortunately I didn't notice some of the rust hitting the undercarriage of my 2004 Yamaha Grizzly 660, but saw it the other day when I was doing some maintenance, oil change, air filter, spark plug, etc. The left side footrest broke and that's causing the plastic to hit the front wheel. It broke right at the welds from too much rust. Looks to me like what I need is (looked this up on yamahapartshouse.com):

YAMAHA FOOTREST BOARD 5KM-27481-10 Left side (broken)

YAMAHA FOOTREST BOARD 5KM-27488-10-00 Right side (rusted and will probably break eventually)

2004 Yamaha Grizzly Foot Rest Assembly

 

Does anyone have a less expensive source? I did see on ebay a couple of listings but it still comes out to @ $50 each, 

Share this post


Link to post
Share on other sites


On 9/17/2017 at 11:10 AM, davefrombc said:

Is it something  a little  cleanup  and re-weld  can't  fix ?

probably, but I'm no welder...😑

Share this post


Link to post
Share on other sites

Nobody in your  quadding  acquaintances have  a  small  wire feed  welder? They're  pretty  common  out  here   among the   ATV  and  4x4 clubs.  A light  duty flux core  wire feed  is  not expensive  and will  do all  the welding  you  want to  do  on ATVs  and most  things that  need welding repairs  around a  home  and yard.  They're  not   hard to  learn to  use  and it's surprising  how many  projects  you   will  come  up  with if  you  have  one.   Sorry  I can't  help  out  from the other  side of the continent.  My  wire  feed  gets  a fairly  regular  workout.

Share this post


Link to post
Share on other sites

I ended up getting these on ebay before the holidays. They were used and I had to drill out some of the bolts, but issue solved.

2004 Yamaha Grizzly Foot Rest

Yamaha Grizzly Foot Rest

  • Like 1

Share this post


Link to post
Share on other sites


Drill and bolt up ? Stainless hardware?

I’m  constantly snapping bolts exactky like this. I wind up using stainless nuts bolts and lock washers with thread lock but wondering if you went a diffent route. 

Share this post


Link to post
Share on other sites
5 minutes ago, Frank Angerano said:

Drill and bolt up ? Stainless hardware?

I’m  constantly snapping bolts exactky like this. I wind up using stainless nuts bolts and lock washers with thread lock but wondering if you went a diffent route. 

I drilled out the old broken bolts on what they sent me which only holds the plastic on. Using new bolts and nuts with lock washers. Used the old bolts to mount to the frame. I think over the summer I'm going to take some of the plastics off and remove rust and coats some of the metal.

  • Like 1

Share this post


Link to post
Share on other sites

It is amazing how fast they rust, i drilled out a few bolts holding my plastics on while working on my recent project and while doing so it got too hot and melted the plastic 😢 and the hole was about 3/4 of an inch since it was a large pan head type bolt that held the plastic to the metal bracket. I had to use a large washer to rebolt the plastics up due to that screw up.  But def go with the stainless if you can.  

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, Frank Angerano said:

It is amazing how fast they rust, i drilled out a few bolts holding my plastics on while working on my recent project and while doing so it got too hot and melted the plastic 1f622.png and the hole was about 3/4 of an inch since it was a large pan head type bolt that held the plastic to the metal bracket. I had to use a large washer to rebolt the plastics up due to that screw up.  But def go with the stainless if you can.  

I just went to home depot for something else and forgot to pick up bolts! Damn... It is amazing how they rust and corrode. Good tip, thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Well today I started on the other side because I only did the one side when I started this topic. I Actually started off today taking my front wheels off to check a brake squeal but ended up pads were still good. I think my wheel bearing is squealing. I sprayed some lube and it seemed to stop, so we’ll see. Thought it was the backing plate or cracked pad but they were fine. 
 

83F8EEFF-0EFE-44C5-BCAF-17DBDD2FD5F1.thumb.jpeg.0004173140755a0bed5e643c47c8f4cd.jpeg

A4CB75DF-F215-4D98-B7B8-66DD9D8ED2D7.thumb.jpeg.f6cd9633058dfed50b1295449190a808.jpeg

884A53EF-EE78-46A4-BA41-27934C1492EF.thumb.jpeg.b364e9da9d913626d06213df5a35d80c.jpeg

Still have this used footrest, drilled out the broken screws. Just coated it with some rust converter and will spray it tomorrow.

5A221413-8BD9-4A83-8CB7-E78647680FF0.thumb.jpeg.75549ca2f98b78a1fa5b23e2502bb373.jpeg

Chipmunks made a mess of under the seat wiring. Had to address that..

D544D817-1048-4885-A520-DD4576C4567D.thumb.jpeg.6f7e279c558cf407409ea9f567ee825b.jpeg

 

Share this post


Link to post
Share on other sites


Holy crap @Ajmboy which one was it, Alvin, Simon or Theodore? 😂

You had the footrest laying around ? That’s great. 
My bear tracker had a mess as well. Just not sure what type of rodent  did it.  Why do they always go for the battery or the air box compartments???

  • Haha 1

Share this post


Link to post
Share on other sites
13 hours ago, Frank Angerano said:

Holy crap @Ajmboy which one was it, Alvin, Simon or Theodore? 😂

You had the footrest laying around ? That’s great. 
My bear tracker had a mess as well. Just not sure what type of rodent  did it.  Why do they always go for the battery or the air box compartments???

I ended up buying 2 on ebay used in January 2018 so the other one was laying around. Over the summer it finally broke so before the winter comes I figured let me get it installed. Alvin chewed through my wiring for the winch remote (which I can't even find anymore)..lol. The other side I had fixed still going strong.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Chris2018
      I have a 1996 Kawasaki Mojave KSF250. I have no manual on it and it has a no spark issue. If anyone could give me a hand with this or would possibly have a manual would appreciate it. 
    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By Tinscissors 428
      I have a 01 blaster kickstart won’t work but bump start does work
    • By StolenATV
      Blue and White Raptor 90
      White, Black and Yellow Raptor 90
      Blue and White WR450F Motorcycle
      VIN’s for ATVs
      RF3AB11Y2HT006593
      RF3AB11Y5HT006815
      Stolen from the yard at my home at night on 10/26/19.
      $2,000 reward for information leading to their return.
      The post Two (2) Stolen Yamaha Raptor 90 ATVs and a Yamaha WR450F Motorcycle appeared first on STOLEN 911.
      View the full article
    • By quadtech62
      I have a 02 Warrior i am trying to build a wiring harness i have looked in the manual and  i am confused... the pick up has 2 wires.  W/R W/G The source rotation coil has 2 wires. One is Red other is white/blue. The manual shows the  the white and blue wire connected to the w/g  right after the stator... so why is these 2 wires connected?  Does not show w/b wire at cdi 
      i have looked at many options with no luck if someone has a 2002-2004 warrior and can take a pic of the wires and location at cdi i would really appreciate it. Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...