Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Timberwolf87

1998 Yamaha timberwolf 250 2x4 air box boot

Recommended Posts

Hi I'm trying to find a replacement rubber boots from carb to air box but having no luck can anyone please tell me if a different year timberwolf or a 4x4 timberwolf will be the same?

Share this post


Link to post
Share on other sites


Should be   easy to  find some hose the right  diameter  in an  industrial or  automotive  supply if you  can't  come up with an  OE  hose.  A  lot easier  replacing a straight one than  one  with  some  bends in it. You might even  find some the right diameter  in a  plumbing supply.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Buell
      Hey guys, figure you guys would have some helpful direction or answers.
      So, 05 Sportsman 700 carb, new carb, fuel pump, new plugs, new air filter, new everything I can think of that is usually the running issues. Starts up fine, seems to run fine, but if under load, two people, or even one person, up a hill, or pulling a drag chain for the driveway, it starts to cut out and sputters and loses all power, until I back off on the throttle and just barely try to let itself catch itself and then I can take off again.
      I am going crazy trying to figure this thing out. Other than that, the quad runs great. Parents bought bran new, just used around the property, 5000 miles on it. Any ideas???
    • By Ellery Zandt
      Does anyone have a redcat 250 or falcon 250cc that they can share where the two vacuum lines on the carburetor that you run antifreeze through I honestly have no idea where the lines are suppose to go to circulate the antifreeze. 
       
      Any help is greatly appreciated. 
       
    • By cheriah
      Ok guys be easy got a lady here. Yes blonde, but not dumb:yes: Just got the new starter for the quad and wondering if I "really" need a clutch puller since I have to take both primary and secondary out to access the starter? I don't have one.
      Has anyone done it without one?? I'm gonna start on this tomorrow am so any and all comments will be appreciated,,,a little nervous bout removing the clutch anyway.....wish me luck!! thanks!!
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
  • Similar Tagged Content

    • By Dee Wilson
      Hey there,
      The short of it: I'm getting a single click when I hit the start, and nothing else.
      The long: I'm a new owner to a 94 Timberwolf. I inherited it with the understanding that it needed a battery. It started without the battery when jumped, so I know it does work. I got the appropriate battery, charged it, and its reading 12.7V. Installed it, and all I'm getting is that click. Cleaned the carburetor today and reinstalled under someones advice, but still nothing. I'm gonna take the battery in to autozone to get it checked, and I was going to head to the spark plug next. But like I say, I'm new to this. Thanks for any and all advice.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...