Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mywifeknowseverythin

Soooooooo,,,,,Its been awhile!!!! Whats new...Hmmmmmm

Recommended Posts

Soooooooo,,,,,Its been awhile!!!! Whats new...Hmmmmmm...Where to start. 

My son has now turned 16...We worked feverishly on his new ride. His Daily Driver now. 1969 Ranchero. IMG_1852.thumb.JPG.4c67808742646b1d0721ca8bda5a702f.JPG

 

IMG_1983[1].JPG

IMG_1383.JPG

IMG_1384.JPG

IMG_1587.JPG

IMG_1593.JPG

IMG_1758.JPG

IMG_1765.JPG

IMG_1769.JPG

IMG_1772.JPG

IMG_1774.JPG

IMG_1775.JPG

IMG_1788.JPG

IMG_1796.JPG

IMG_1805.JPG

IMG_1808.JPG

IMG_1827.JPG

IMG_1841.JPG

IMG_1842.JPG

  • Like 2

Share this post


Link to post
Share on other sites


When he turned 16 I gave him the Raptor 700R. We had to basically rebuild the fuel pump, install new injector and new battery. Fired right up!! That POS had been in the garage untouched since 09. I hate that thing. He loves it though. 

IMG_2162[1].JPG

IMG_2155[1].JPG

IMG_2594[1].JPEG

  • Like 1

Share this post


Link to post
Share on other sites

Also,,,,I have spent this past year in the hospital...Something that I have been putting off for 12 yrs finally caught up with me and almost killed me. My large intestine ruptured. Had to have 2 feet removed. Wish I would have had that fixed all those years ago..I feel like a new man. Anyway,,,Non of this is TRIKE RELATED!!!!

 

Share this post


Link to post
Share on other sites


Wow he's got some awesome rides there! I see you have a lift outside, air tools, the works. Is that at your house? Very cool, that's what I need a lift. I can appreciate the cars being in the auto industry with repair and now parts for over 25 years. There are just not enough of the younger generation getting into and rebuilding older cars, so it's great to see. Great photos and tat BTW. 

Glad to hear you are doing well and like a new man! If I remember correctly, you were one of the first that I see with a CanAM spyder, do you still have that and your trike?  You were part of that 3wheeler group also, right? You also had an RZR, right? 

Yeah not trike related, but had to reply because so psyched to see you visit! 😝 Maybe I'll move these into a new topic. 😎

Share this post


Link to post
Share on other sites
3 hours ago, mywifeknowseverythin said:

Also,,,,I have spent this past year in the hospital...Something that I have been putting off for 12 yrs finally caught up with me and almost killed me. My large intestine ruptured. Had to have 2 feet removed. Wish I would have had that fixed all those years ago..I feel like a new man. Anyway,,,Non of this is TRIKE RELATED!!!!

 

@mywifeknowseverythin I split the topic and created this new one 😁

You gotta chime in on this one also...:notworthy:

 

Share this post


Link to post
Share on other sites

That's a great pic with him standing where the engine is supposed to be! That motor is looking good. That's the get Smart car! Pretty cool.

Share this post


Link to post
Share on other sites

Wow man. Great pictures. You guys are very hard working. I am impressed by your work.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JacobSlabach
      i know this isnt an atv but same type of thing.  I have a riding mower im fixing and selling for my aunt and it has a dead battery.  i jumped it off my atv and when i turn the key nothing at all happens.  i tried jumping the relay still nothing.  this is with the seat down.  you wouldnt think this mower would have issues as its a top-of-the-line brand and almost brand new (aunt found it for a good price, still got tits on tires, just sat for a couple months in a mechanic shop
    • By bradley nelson
      Im cool with the police in my area so i can ride on public roads.
    • By Charlie Garcia
      Any public trails near Prattville Al?
    • By Mark Walters
      Hi guys.  First post, hope you can help.  As above 1991 Honda fourtrax.  Starting, running fine until a few weeks ago. Used primarily to put my ski boat in the garage (put 2" ball on front).  Any way, had just backed boat into garage, turned off to crank trailer wheel down, when I went to restart got nothing.  
      No neutral light, no headlights, no reverse light, would not turn over when start button pushed.  It would crank and run when I jumped the contacts on the start relay.  While running the neutral light will come on, although it is dim and flickers.  Reverse light on when running and in reverse.
      What I have done to this point:
      1.  Used jumper cable to ground battery (-) terminal to engine block thinking ground wire from battery to engine may be bad.  No neutral light, no start.
      2. Applied 12 volts to start relay.  Got a loud click like it was making contact.  I didn't have the battery/starter cables connected to the relay, but I am assuming it would have cranked at that time.  
      3. Disconnected neutral switch wire.  Grounded neutral switch wire with jumper wire. No neutral light, no electric start. 
      At this point I am thinking ignition switch vs broken wire in the harness going to the neutral switch (due to dimness and flickering when running).
      Any and all suggestions to help track down this issue are appreciated.
      Thanks
       
    • By uzejo
      My lakota has a new carb and just had a top end redone by a professional, but it will not start. The electric start turns it over great, there seems to be compression. It seems like its trying to start, getting right there and just doesnt catch. It does start occasionally, but wont run for more than a couple of minutes and smells rich. Im assuming the carb needs to be tuned, but im just wondering if anyone else has any ideas before i get a chance to work on it.
       
      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...