Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Jacob Blocker

Suzuki Eiger ATV smoking after new rings

Recommended Posts

I got an ATV from a guy that ran out of time rebuilding an eiger 400. He put a nerma Piston and rings in. I finished it up and it smoked like a train. I took the head off and honed the walls and it looked like the rings where on the walls, but it smokes just as much. I'm confused what's wrong with this thing.

Share this post


Link to post
Share on other sites


What year is the suzuki eiger? Are you using the correct oil? From how you describe it, it sounds like oil is getting into the combustion chamber. How's the air filter look, is it oil soaked?

* Added ATV info to topic title and moved to Suzuki forum.

Share this post


Link to post
Share on other sites
2 minutes ago, Ajmboy said:

What year is the suzuki eiger? Are you using the correct oil? From how you describe it, it sounds like oil is getting into the combustion chamber. How's the air filter look, is it oil soaked?

* Added ATV info to topic title and moved to Suzuki forum.

its a 2007 with like 4k miles. I did not have the filter on when testing it.

Share this post


Link to post
Share on other sites

some smoking is normal for a break-in period but if you are getting excessive smoke it could be the wrong size piston/ rings setup, were the rings in the correct order? were the ring breaks alternated on the piston? hope this helps!

Share this post


Link to post
Share on other sites
7 minutes ago, steve shugart said:

some smoking is normal for a break-in period but if you are getting excessive smoke it could be the wrong size piston/ rings setup, were the rings in the correct order? were the ring breaks alternated on the piston? hope this helps!

I didn't replace the Piston and rings so I'm not sure the sepcs or anything. I got new rings just to make sure there right and I'm replacing the valve seals also. I also got up sized rings if I need them.

Share this post


Link to post
Share on other sites


39 minutes ago, mark7170 said:

Any updates on the smoke issue?  I'm about ready to go after a similar problem.

I ended up just buying a new jug and piston set and it fixed all my problems. If it's not smoking to bad and you haven't let the engine run for to long I'd let it run for a while first.

Share this post


Link to post
Share on other sites

check compression and do valve solvent leak test

Share this post


Link to post
Share on other sites


On 7/15/2018 at 1:15 PM, Jacob Blocker said:

I ended up just buying a new jug and piston set and it fixed all my problems. If it's not smoking to bad and you haven't let the engine run for to long I'd let it run for a while first.

Nice

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By ray desocio
      I posted earlier looking for a wiring diagram, but maybe someone can help me with the problem if they’ve had it before. 
       
      The quad Will start and idle ok, when I open the throttle it will rev all the way up until WOT and then it dies back down to idle, and if I keep the throttle wide open it will rev back up. It will do this over and over and over. 
       
      I replaced the carb, (twice), Rectifier, battery, and spark plug.  The Stator ohmed out to the proper specs from dinli.  The other issue i can see is I’m not getting 12v on the choke circuit. The lights don’t work either. 
       
      possible bad key switch? Maybe the new rectifier is bad? All the contacts on the key switch also ohm out properly    
      comprsssion is up to 125 psi and spark is there. 
       
      Reed valves look great.....
       
      im at a loss. Any trouble shooting advice would be appreciated. 
    • By bren7176
      So time to purchase the new piston and rings for the 1995 Sportsman 400 . Looking for some input on this like what would be the best to buy ....
       
      thanks
       
      Brendan
    • By bren7176
      So honed out the cylinder and got most of it nice nice but left with this .. Might just have to have the things bored out now ..... some before and after..pics.
      1995 Polaris Sportsman 400 4x4 
       
       

       
       
      have to have the things bored out now ..... some before and after..pics..









    • By erthsole
      Where do you buy your ATV gear? I am planning to buy a swing arm guard, heavy duty bumpers, chassis armor, nerf bars and grab bars for my 2003 Suzuki EIGER 400. Any recommendations?
  • Similar Tagged Content

    • By Cody Smith
      Does anyone know the exact name of this part? Bottom of tire is tilting in Under the bike and top or tire is tilting out away from the bike. Not terrible but it’s a little 90 for kids want to make it safe. Just need to know exactly what the part is called. 



    • By Sombeech
      I shot this footage last weekend. We ran a Honda Foreman along the beach and had a great time wakeboarding.
      Helmetcam footage.
      There is also a download link for the YouTube Challenged employees at work.
    • By Arizona
      Went shopping on Saturday, picked up another Kawasaki Bayou 220 and a Yamaha Timber Wolf 250
      I really should sell some of these but they are a lot of fun to find, fix and ride
      Of course neither of them run but that's part of the fun!  Az



    • By oxidized_black
      these are what i have in my collection ... always looking for more
      Linhai (german)
      http://rapidshare.com/files/3880403675/Linhai%20(german).rar
      Linhai 250 - 360 Service Manual
      http://rapidshare.com/files/582921063/Linhai%20250%20-%20360%20Service%20Manual.pdf
      Linhai 260 - 300 Parts Manual
      http://rapidshare.com/files/1587211864/Linhai%20260%20-%20300%20Parts%20Manual.pdf
      Linhai 260 - 300 Service Manual
      http://rapidshare.com/files/3400427719/Linhai%20260%20-%20300%20Service%20Manual.pdf
      Linhai 300 Parts Manual
      http://rapidshare.com/files/1938660329/Linhai%20300%20Parts%20Manual.pdf
      Linhai 260 Service Manual
      http://rapidshare.com/files/218261873/Linhai%20ATV%20Service%20Manual.pdf
      Linhai Bighorn CUV Service Manual
      http://rapidshare.com/files/2459140573/Linhai%20Bighorn%20CUV%20Service%20Manual.pdf
    • By Zacharia Maisonneuve
      i have a 1993 timberwolf yamaha and the compression is good and lights work but for some reason the electricity is not going to the spark plug(s)! i got a friend to check it out and they said its no use but im not giving up! please help with this!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...