Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
ATVNetwork

2019 Can-Am Outlander X mr Models

Recommended Posts


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By colin james
      View File 2017-2019 sportsman 450/570 with eps factory service manual
      This  is the factory service manual for the 2017-2019 factory service manual for the sportsman 450/570 with electronic power steering 
       
      Submitter colin james Submitted 09/06/2018 Category Polaris ATV  
    • By quadcrazy
      We are starting this topic so that members can share their view about ATVs; what they are used for, types, etc. This topic is intended to help new members and visitors and generally those that don't know much about ATVs and would like to learn. So anything you can add to this topic that you feel would benefit a new comer, please add a reply..
    • By Palooza
      Headlights on my Outlander 570 are junk.  Would like to upgrade to a light bar.  What is the max size (wattage) that it can handle? 
      Can I just split into the high beam wire for an install.  I see YouTube videos of a separate switch that hooks up straight to the battery, but wouldn't that drain the battery if the machine is off and lights cold be left on by accident.
      I'd like to hang it from the front rack as I have a basket installed on the rack that I would like to keep there.  If anyone has done this, please send a picture!
    • By jimybud
      Below is a quote from a response to similar question from yesterday: 
      "Easiest thing to check is trash in the main jet.  if it idles fine, then the idle circuit and low speed jet is clear.  if it bogs off idle that's when it's transitioning to the main jet." 
      I will go ahead and open up the carb and check the main jet, but please respond to this post as if the main jet is squeaky clean.
      Below is my post:
      Only starts and runs on Full chock. 
      Does not matter what position I have my "mixture" screw.   Tried it at zero, 1 turn, 2 turn, up to five turns.  Spent a few hours confirming that the position of the mixture screw does not resolve issue.
      Runs great at idle and if I slowly engage throttle, it will rev up as expected.  But, quick rev up or when I am trying to drive it, it spits and sputters and looses power.
      I also use a propane bottle and did not find any obvious leaks, and the vacuum port is hooked to fuel peacock and I also made sure to simply block the port with my finger to see if that would resolve the issue.
      New Carb (after market), New Coil, Fresh Gas.  No leaks at manifold boot, hot battery.  Good gas flow.    Runs too good to be a valve issue, or cylinder, great compression.
      I can move the choke out a tiny bit, and it will still run, but will still bog down when I try to power it up.
      I also have a 250 trail boss Polaris that I require to run at full choke, but it has power at all throttle potions.
      I suspect it is running rich as the choke is on, but will not run with it off.
      Any details would be appreciated.
    • By fishinnnc
      I just bought this thing and got the carb all cleaned today and it was running like a champ. There was a spare hot wire hanging down that was not hooked up to anything. I found it when I took all the covers off and did the carb work. Unfortunately I forgot it as well when I fired her up after cleaning and replacing the carb. While I was running her, the wire was lying across the exhaust pipe. The exhaust got hot, melted the insulation and next thing I know I see sparks flying everywhere Bike immediately shut down and all lights went off. I have nothing on the console now when I turn the key over. I fear I have fried my ECU. I found one fuse back by the box, a 30 amp, but it was good. Are there any other fuses on these things? Is there a way to test the ECU? Could it be the rectifier or voltage regulator?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...