Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
ATVNetwork

5 Affordable Tie-Downs For Your ATV/UTV

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Buell
      Hey guys, figure you guys would have some helpful direction or answers.
      So, 05 Sportsman 700 carb, new carb, fuel pump, new plugs, new air filter, new everything I can think of that is usually the running issues. Starts up fine, seems to run fine, but if under load, two people, or even one person, up a hill, or pulling a drag chain for the driveway, it starts to cut out and sputters and loses all power, until I back off on the throttle and just barely try to let itself catch itself and then I can take off again.
      I am going crazy trying to figure this thing out. Other than that, the quad runs great. Parents bought bran new, just used around the property, 5000 miles on it. Any ideas???
    • By Dwight Williams
      Ok, so I bought this scream of a deal the other day - a 94 King Quad 300 for $40.00.  It's been sitting outside with no carburetor on it for about a year.  Its rusty, missing some parts, wiring is all cut up and spliced etc.  No seat, no racks but the plastic is all there minus the headlight housing.  Anyway, who can pass up a $40.00 quad right?  I get it home and looked at the sight glass for oil level, it's about 1/2 oil and 1/2 water.  I drain it, refill it and turn the motor by hand (recoil starter is missing) and it turns over just fine.  I worked on the wiring for about an hour and got it to turn over with the electric starter and got enough of it sorted out to get a spark.  Did a quick compression test, 70 lbs.  Wet test bumped it up to 90.  Ok, so rings and cylinder washed out with water for a year, not too surprised.  I thought 'what the hell' and sprayed some starting fluid in it and it ran for about 2 seconds - enough to show  it's got life.  Since then the compression has gotten worse, I can't get enough pressure to activate the carb diaphragm, therefore no fuel pump either.  The compression is now around 60.
        Anyway, my question is....is it worth it to try to get this thing going?  I tore the top end down today and the cam and one of the rockers is pretty worn.  I figured a top end job would be about $100 or so, depending on the condition of the cylinder but I'll probably have to put a cam and rockers in it as well.  Doing some research on ebay I figure I'll have to spend about $500-$700 to make the whole machine right again.  Much less just to make it run and use as-is but I won't really like it until it's right.  I don't mind doing the work, I actually enjoy it but I'm concerned about what all that water did to the rest of the internals, I can't really test it all out until I can make it run.
      I know it's a basket case but I'm not into it much at all, even if I do the top end and find something else wrong I'm still not out much.  I'm leaning toward ordering the top end parts and going from there unless you can convince me otherwise - any way to check the rest of the internals without tearing it down?  I plan on flushing the oil cooler before I do another oil change, I've drained it twice now and it gets milky almost immediately just turning the starter - I suspect the oil cooler is polluted badly.
       
      I'll get some pictures today if anyone want to see them.
       
      thanks!
    • By jrhoads23
      Does anyone know of a tall windshield option for a 2017 Sportsman 850? I was looking at the Polaris one (need to buy the fairing and the windshield separate) but I was curious if anyone has tried any aftermarket and liked them?
    • By Twilight228
      Good Morning All!,
      After a significant amount of reading and tinkering, I'm stumped.  We have a pair of Arctic Cat DVX 90s (4-stroke), and one of them runs very rich at wide open throttle.  I've cleaned the carb (which was installed new  last year), verified the main jet (80) to be per the original spec, installed a new air filter, tried a hotter spark plug (CR6HSA), and adjusted the valves (tightened a modest 0.0005" but improved starting).  The hotter spark plug may have help just a bit, but not appreciably.
      Just for fun, I swapped the CDI between machines, and that didn't help either.
      Fouling plugs very quickly, but not to the point the machine will not run or start.  [black instantly]
      Logically, I assume I'm revving out, but the other machine doesn't "stumble/blubber" anything like this one.
      Should I try a smaller main jet?
      Any ideas you guys may have would be much appreciated.
      Thanks in advance everyone.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...