Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Jerry Redhage

2003 Arctic Cat FIS 500 Steering Problem

Recommended Posts

Recently have had a hard right pull develop on the above vehicle. The problem started and then the unit was buried in a muddy field edge. After extracting the unit from the mud the problem was worse and Have done the following;
- Completely washed the unit of all mud and sand.
- Brakes were muddy and filled with sand so I cleaned and sanded rotors and replaced pads on left/right front and right rear and checked auxillary brake.
- Left axle had a torn outer boot and showed signs of wear so I took the left side apart and replaced the axle and reassembled.
- Topped off both front and rear differentials and added grease to the left upper ball joint.
- Burnished new brakes and unit would still pull hard to left especially when slowing down.
- Jacked front end up and put unit in 2 wheel drive and turned front wheels and they both seemed to be free and turned similarly and free wheeled without any noticeable problem.
- Brakes appear to be working properly and release when released.

Unit still pulls hard right and the tendency get worse as the vehicle is driven. Right CV axle boots are intact and not torn. I have not been able to break loose the axle nut on right side to check the outer bearing as of this time. If you slow down the unit will turn hard to the right unless you firmly prevent the handle bars from turning. No apparent noises from from end except slight scuffing of brake pads on rotors when you spin the tires in 2WD drive and elevated off the ground.

Any suggestions on what to check next would be appreciated.

Jerry Redhage
 

Share this post


Link to post
Share on other sites


First, here is a link for the service manual for your machine

http://www.mymowerparts.com/pdf/Arctic-Cat-ATV-Repair-and-Service-Manuals/Arctic-Cat-2003-ATV-Service-Manual/

One of the sections will explain how to check the steering, tie rods, and castor.

First thing to do is check the front tire pressures. If one tire is low, the quad will want to pull in that direction.

Mike

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By Frisbie6
      This is a strange question maybe.  I just finished cleaning my old barn find Suzuki.  I think it's a 1985.  LT230 shaft drive.  Started it up and other than making some carb adjustments (well, I think that's all I have to do) it runs fine.
      But as I drove it around the yard I noticed that it is hard to steer.  The front tires seem like they are barely touching the ground!  The handle bar moves fine and the wheels turn, but the tires don't grip the grass.
      When I lean forward as far as I can the tires actually bite into the grass and turn the bike.  When I sit on the bike it just plows straight ahead.
      Has anyone seem anything like this? 
      I wonder if the back tires are too small, causing the bike to lean backwards.  Does anyone have the specs on what size tires I should have?
      Thanks for any help provided...
    • By Rob113
      Hello guys! I ride a triton 450 super moto. i hawe change connecting road... Now all is okey,test drive ok manny km done. But there is one problem...i hawe buy a new accu. But the starter is verry hard rotate...almost stops.  So the motor is wery hard to start. I hawe trie connect the starter directley to accu and its the same thing.Before rebuild the starter has work normal.
      What hawe i done wrong?
      Sorry for my English:)
    • By ron755
      I have a 94 Yamaha Timberwolf 250 4x4. I have no fire to the ignition switch, no nutral light, head lights, or tail light I can jump across the selinoid and start it. I put on a new solinoid. The neutral light comes on,while running, but dims when you give it throttle.
      Would this be a relay, not letting fire go to the key switch? If so, could someone post diagram from a manual, on how to test the relays?
      Thanks for any help
      Ron
    • By johncb
      My brothers 06 outlander max 400 shifter lever is very hard to get into the correct gear any ideas what the problem could be?
    • By Thomas Aucoin
      My Arctic Cat will not suck from the fuel tank and start. I replaced the Carburator, fuel pump, spark plug, air filter and hoses. I can run a fuel line to a gas can with the top off and drop the fuel line in it and it will start. So I was thinking I had a problem with my fuel tank but I can siphon fuel out of it
      So I bought a portable 6 gallon tank and mounted it on the luggage rack but it will not suck out of the new tank. But if I take the filler cap off and drop the fuel hose in the tank it run suck gas and run
      Any suggestions? Electric fuel pump?
  • Recently Browsing   0 members

    No registered users viewing this page.


×