Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Debbie Jim Mills

2019 500 Suzuki king quad

Recommended Posts

Just picked up my new quad from dealership. Drove it onto truck felt for brush guard to touch front of bed. There isn't one.  Asked dealer. Says they don't come with one have to order it. They looked it up not available for at least 30 to 90 days. Winch mounting plate either. Been riding suzuki's since 1973. So i guess it will have to sit in garage till accessories are available. This is my fourth Suzuki ATV they all came with brush guards. Can't even imagine the damage you could get without it. 

Share this post


Link to post
Share on other sites


Congrats on the new King Quad! Post some picture, would love to see it. I'm a fan of king quads, had one a few years back. As far as parts, sometimes when they are the latest model year, parts go fast.

Share this post


Link to post
Share on other sites

Did you ever get your brush guard? I just bought a 2019 King Quad, with no brush guard , or winch, made me kind of hesitate buying it honestly but i had 2 Suzukis previous. Taking the cheap there and running up service fees are making this the last suzuki i ever get

Share this post


Link to post
Share on other sites
4 hours ago, Edcl54 said:

Did you ever get your brush guard? I just bought a 2019 King Quad, with no brush guard , or winch, made me kind of hesitate buying it honestly but i had 2 Suzukis previous. Taking the cheap there and running up service fees are making this the last suzuki i ever get

Congrats on your 2019, post some pics! I'm a fan of king quads 😋

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Edcl54
      Bought a 2019 king quad 500 AXi few weeks ago.  What are peoples feelings on the break in time and fees a dealer charges.  Not sure if i should do the break in service myself. Thanks
    • By RockOn
      So I bought a 2001 Quad Runner 250 for my son/wife. Sorry I run a Grizzly 660.
      I’ve rode it many times with no issue.
      My son’s first time out, I could always hear him but feeling he ran it red line in first gear a lot.
      So this is what it was doing during/end of the 2-3 hour ride:
      - halfway though noticed smoke (oil) coming from front of the motor sort of under exhaust manifold. Once back at the truck, it was really noticeable. Definitely oil burning off. I’m thinking from the top end maybe.
      So quick inspection:
      - No leaks or seepage of oil that I could see
      - I pulled the plug and it’s black but not wet
      - No blue/white smoke in exhaust
      - seems to still ride fine
      - Engine still has plenty of oil
      But now that I’m looking at it back at the house - it’s a hard/won’t start when hot. It starts right up cold no problem but once it stalls when hot, have to let it sit for 10-15 before it will start again.
      It wasn’t idling before that trip so I jacked up the idle a bit as well but I think that’s a carb clean/adjustment but...
      Any input is appreciated.
      Thanks for any help.
       
      Sent from my iPhone using Tapatalk
    • By Shane Pillar
      Talk about what kind of atv you have and what you do with it.
    • By LMI
      Hey all,
      It's been a while since I posted.  Fan trouble and the replacement I sourced on amazon is still working great on my 2005 Suzuki KQ700.
      Unfortunately this year I lost my outdoor best friend.  He's that go to guy for everything … the day run, may walleye opener, last minute hey my boat's at work get your a$$ over here with your rod and let's go kinda buddy.   I bought the quad last year in March and with him gave it the once over and prepped it for fall hunting season, but cancer took him before we could enjoy this new aspect of outdoor life.  We planned an October trip into the bush with our quads guns and tent trailer.   It never happened.   A tribute to our fallen and lost.... But in their memory take the opportunity to grasp every minute of the outdoors you can, life is short... you can sleep at the end...
      I've curious what everyone has been doing to prep for the spring season.  I mounted my battery and the quad started up straight and easy, just powered it up once or twice to juice the injectors and it fired up after a couple of seconds.  I let it run, confirmed fan started, checked charge voltage.  all good. I did all my oils in the fall to make sure no water was present anywhere so skipped that this spring.
      So what have I done over the winter to prep for quadding?  I've been researching.  This year I am going to cross over quading with brook trout fishing.  So I have been pouring over my old maps from my youth, google maps... looking for those faint markings of trails I can't travel in my F150 (well not yet, paint still looks pretty good ).
       
       
       
       
    • By jerebear
      I rebuild my front diff but can't find the torque spec for the pinion nut for my 1998 500 quadrunner. It had timkin bearings so I know the preload needs to be correct not to overheat or be too loose and take it out again. Does anyone know what the correct torque is.
      Thanks 
  • Similar Tagged Content

    • By Edcl54
      Bought a 2019 king quad 500 AXi few weeks ago.  What are peoples feelings on the break in time and fees a dealer charges.  Not sure if i should do the break in service myself. Thanks
    • By Alex91
      I have a 92 suzuki king quad that seems to be getting way to much fuel in my spark plug hole as I took out plug cranked it over and covered myself in fuel I cleaned carb and fuel filter and fuel pump all seems fine any other ideas
    • By KQ300cy
      Hi all, new to the forum, looking forward to getting some help/advice on maintaining an 18 yr old atv!  So my King Quad 300, recently started running really rough (otherwise ok til this point) at anything more than idle.  After started, choke on/off, doesn't seem to matter, it shutters (Not sure how else to explain it) really bad when given throttle.  I can let the engine run for several minutes, but this never improves.  
      Fuel pump checks out ok, and I don't see any gas in the fuel pump vacuum line.  I am a novice on a carburetor, but I need to see what's going on, so after taking it apart, I have a question about this plastic part with an o-ring that is above the jet needle.  Appears as if someone rebuilt this carb, because it is extremely clean...so I am wondering if this plastic part looks to be typical for this carb...or not.  Thanks in advance for the help!



    • By Wolds Alpacas
      I have just ordered a Suzuki King Quad 300 which should be here this week - it is described as "with slow running needing attention"  I am as a matter of course going to put a new spark plug in, change the oil and oil filter and blow out the air filter with compressed air - anything else I should consider?  Also, the headlights do not work - I want to change them out for LED ones anyway though. 
    • By David Land
      I have an 05 King Quad 700 that has in the past had to have the stator replaced twice.  For the past six months it has been down hard as I cannot get it to fire.  I have replaced the coil (which is the code that came up) and now I have a friend replacing the stator.  I want to see if the new stator does the trick.  Drain the old fuel, and replace with 100% Ethanol free fuel, and see if that does the trick.  The local Suziki dealer will not work on it as it is over 10 years old.  So the nearest dealer is 90 miles away.  The last thing I can do after that (provided the other fixes do not work) is replace the ECM/ECU.  I also read that there was a recall on the ECM/ECU, so I need to check on that.  All of the grounding has been checked, so if anyone has an idea, I would greatly appreciate the insight.
       
      Kindly,
       
      David
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...