Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Rca Media Box

Hello from Nova Scotia

Recommended Posts

hi, i have acquired a 1990 bigbear 350 and I'm fixing it up and going to ride it. The engine is strong but the rest needed some love. I'm on a shoe string budget so it is taking some time. But almost there. Read some posts here and i like what this forum has to offer. And hope i can add to the community.

Share this post


Link to post
Share on other sites


Good luck with the big bear, I just bought a 97 big bear 350, I really like mine so far. Seem to be great machines.

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By Zilla28
      While riding my Quadzilla XLC 500 I was cruising along about 60 mph then opened it up, but once I hit 70-75 mph it died on me so I rolled to a stop and it wouldn't start for about 20-30 seconds. I then noticed the Temp light occasionally flashes on but its so quick you wouldn't notice in the day so not sure how long its been happening. The engine has started pinging when I accelerate which can be caused by many things so I drained the fuel and replaced with hi octane, fitted a new spark plug, adjusted the little washer on the high jet in the carb twice to make it run more lean which made no difference.  I tested the thermostat which opens at the correct temperature, I removed the radiator cap and started the engine and no bubbles were showing and the oil is on maximum and very clean as I have not long serviced it.
      The last time I took it out I went 14 miles and the coolant in the bottle has dropped about 1/2".
      I am now leaning towards a head gasket and have purchased a full gasket kit but was wondering if there's anything else it could be before taking the engine apart.
    • By Rick Shropshire
      Happy New Year all! Remember not to operate any vehicles while under the influence, you could get busted or worse, you could get hurt or hurt someone else who's playing it safe and end up in jail. Have fun and be safe.
    • By Petr Hauschild
      my quick video of my trial ride
    • By 4tracker
      So many things can go wrong, while out riding, even when with others, when getting away from the group! Try to always ride with at least one other person! If your over 50 and ride alone let me know, I'll try to go with you. I know the trails pretty good, up north, around St Helen, Mi. or I'll try to try areas of the state your more accustom to. I know its too cold now, but spring will be here before you can blink an eye lol
      I can ride with the slowest dude in the pack, to WOT! Get in touch before season starts for more inf. Thanks, Steve



       
       
    • By joseph
      my atv will start right up will idle fine soon as i try to throttle up engine dies,i have changed gas,new fuel pump and lines great compression 188 lbs.new coil new spark plug adjusted valves dont know what to do also rebuilt carb,any help wanted
  • Recently Browsing   0 members

    No registered users viewing this page.


×