Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Steve h

1987 Suzuki 250 lt 4wd fuel pump location

Recommended Posts



The fuel pump is located in front of the fuel tank towards the front of the machine on the upper frame rail. Do you need the service manual?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      What is the opinion on carb kits? What's one of the better brands of aftermarket? OEM is always preferred but not practical, chinese cheapie is never a good option. 
      Thoughts ?
    • By raybob
      replacing carb,, the bigger line on right side top of carb does it just vent to the air,, cant find where to hook it up to also I want to check the oil and gear oil I checked the oil in motor and the rear end my question is looks like allen plug on left side of motor if you are setting on the 4 wheller, ps it hs a oli leak any help would be great. Ray in kentucky
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Squirrel
      Several months ago, I finally got around to fixing the bayou. Rebuilt the carb, replaced the fuel selector switch, hoses and fuel filter, and she ran great. Only had 2 minor issues since then where, at higher speeds, it acted like it was choking out when I let off the throttle.
      Lately I've noticed if I let it go for more than a week, it almost drains the battery dead trying to start. I initially thought battery, but after inspecting I found very little if not any fuel flow through the line until it starts and runs.
      I'm a little baffled and don't have much time to mess with it as most my free time right now is spent on getting my rv up and ready for hunting season in the next 3 weeks. So any help on quick diagnosis checks would be helpful. Otherwise I'll just keep starting it every 3-4 days to keep things primed until I'm done hunting.
       
      Oh, and another question on a different topic. Does anybody know what the mounting brackets on the front rack are for? I'm referring to the 2 angled metal tabs with threaded holes that are located on the left, near your knee when sitting on the quad?
       
      Sent from my SM-G950U using Tapatalk
       
       
    • By Brad Leeson
      Can someone please tell me where the pilot air jet is located? I can't find anything other than on the pilot jet. It's on a 2005 yfz 450. 
  • Similar Tagged Content

    • By joseph
      my atv will start right up will idle fine soon as i try to throttle up engine dies,i have changed gas,new fuel pump and lines great compression 188 lbs.new coil new spark plug adjusted valves dont know what to do also rebuilt carb,any help wanted
    • By Cory Macleod
      Hi looking for help. My 700 fuel pump won’t cycle when I turn key on also my digital dash is not displaying anything it does light up yellowish but nothing else. If I pour fuel in the intake it will start for second
    • By Resurgence Small Engine Inc.
      This past spring, Jonathan worked on a 1991 QuadRunner 250 that came with the fuel pump removed. We didn't find good information about connecting it online, so we made a video.
      Below is the link to watch Jonathan describe the connections on the Suzuki fuel pump. This applies to both the Quadrunner and King Quad ATV models.
       
      Hope you find it informative!
      Resurgence Small Engine Inc.
    • By mitch1960
      I have a 2002 King Quad 300 that has been a fantastic product until now.  Starts well, idles well, upon acceleration, begins to run rough and won't to very high in RPM.  I assumed fuel starvation or bad plug as the issue.  New plug - no change.  Have checked petcock valve which seems ok.  Also checked pump, and thought that might be the issue.  Called around looking for the replacement pump part, and local store suggested they were pretty reliable, and doubted that was the issue.  Suggested a carb cleaning.  Took the easy way out, and opened up the top of the carb, removed the diaphragm, and put some Seafoam in...and let it sit for an hour.  Upon turning over, it wouldn't fire at all.  After a couple of tries, seemed to get a hydraulic lock.  So, pulled plug and turned over, spitting out a lot of fluid.  Re-installed plug, same response.  Now, getting gas leakage on to floor but haven't been able to trace it down exactly (suspect from carb but not from top where I re-installed the diaphragm).  Any ideas?  Thanks.   

    • By Travo
      Can anyone help with routing the hoses on a lt250 carb hose routing? Manual doesn't really specify much, and pictures are lacking in it
      Sent from my XT1585 using Tapatalk
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...