Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Steve h

1987 Suzuki 250 lt 4wd fuel pump location

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By raybob
      looking to buy good used carb for suz 500 quad master, I got one from china it is junk let me know if you have one and price. thanks Raybob
    • By Trent Finnessey
      So I’ve got a 2000 Honda 400ex absolutely love it!! I’ve had it for about a month, I ride with bruteforce 750’s, outlander 850’s and 1000 sxs’s and I was thinking of getting a trx450r carb and a full hmf exhaust. And probably doing the air box mod too, how much power would this give my 400? Just a little different or a big difference? Cuz if it’s not much of a different I’ll just stick with my dg slip on..... thanks!
    • By Jodawg1981
      How do i find out what carb came on a 06 suzuki ozark 250? Trying to get a new carb and need to know the model number or size. I know its a mikuni. Or if anyone has one let me know
    • By M C
      Hello all!
      A friend of mine has this particular 4 wheeler. It sat in the garage for about a year, so I redid the carb, cleaned the tank and installed a new petcock. So far, it cranks right away whether its button started or pull started. So I have a couple of questions concerning the carb and air filter.
      1. Is this a cvk32 250 or 350 carb? As the air fuel ratio adjustment is different according to a cvk document I read. What's your adjustment setting? 2 whole turns and a 1/8 or 2 whole turns and a 1/2? Comparing the old setting on the carb to the new setting (and where the needle sits now), makes me think it was way off before. 
      2. The Air filter cover, gasket, air filter and plate element are all missing. So I was thinking of removing the hose that goes to the air box and put one of those K&N style looking filters and be done with it. So my question is.. will I have to readjust Air Fuel screw or just adjust Idle?
      It's just going to be driven around the neighborhood.
      Thanks in advance for any info or help. Y'all stay safe out there!
  • Similar Tagged Content

    • By joseph
      my atv will start right up will idle fine soon as i try to throttle up engine dies,i have changed gas,new fuel pump and lines great compression 188 lbs.new coil new spark plug adjusted valves dont know what to do also rebuilt carb,any help wanted
    • By Cory Macleod
      Hi looking for help. My 700 fuel pump won’t cycle when I turn key on also my digital dash is not displaying anything it does light up yellowish but nothing else. If I pour fuel in the intake it will start for second
    • By Resurgence Small Engine Inc.
      This past spring, Jonathan worked on a 1991 QuadRunner 250 that came with the fuel pump removed. We didn't find good information about connecting it online, so we made a video.
      Below is the link to watch Jonathan describe the connections on the Suzuki fuel pump. This applies to both the Quadrunner and King Quad ATV models.
       
      Hope you find it informative!
      Resurgence Small Engine Inc.
    • By mitch1960
      I have a 2002 King Quad 300 that has been a fantastic product until now.  Starts well, idles well, upon acceleration, begins to run rough and won't to very high in RPM.  I assumed fuel starvation or bad plug as the issue.  New plug - no change.  Have checked petcock valve which seems ok.  Also checked pump, and thought that might be the issue.  Called around looking for the replacement pump part, and local store suggested they were pretty reliable, and doubted that was the issue.  Suggested a carb cleaning.  Took the easy way out, and opened up the top of the carb, removed the diaphragm, and put some Seafoam in...and let it sit for an hour.  Upon turning over, it wouldn't fire at all.  After a couple of tries, seemed to get a hydraulic lock.  So, pulled plug and turned over, spitting out a lot of fluid.  Re-installed plug, same response.  Now, getting gas leakage on to floor but haven't been able to trace it down exactly (suspect from carb but not from top where I re-installed the diaphragm).  Any ideas?  Thanks.   

    • By Travo
      Can anyone help with routing the hoses on a lt250 carb hose routing? Manual doesn't really specify much, and pictures are lacking in it
      Sent from my XT1585 using Tapatalk
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...