Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
ATVNetwork

Thomas Brown Earns First Win of The Season at RedBud National

Recommended Posts

The tension coming into round nine of the 2018 ATV Motocross National Championship (ATVMX) presented by CST Tires, an AMA National Championship, was already at an all-time high as the front-runners were locked in a very tight points battle. As race time drew near, the forecast was not looking to be in favor of the riders lining up.

View the full article

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By joninak
      Well, it overheated then started blowing white smoke!!
      I have it torn down & the cylinder appears to be warped. Going to have the head checked out next but in the meanwhile... Does anyone have the torque sequence/specs for the head bolts??
      TIA
       
       
    • By Jeffrey Jones
      Just purchased a 450 EPS and I'm wondering about accessories. What are some good websites for aftermarket accessories? Looking for front and rear brush guards and LED lights.
      Thanks
    • By ezduzit
      picking up atv tomorrow, guys says motor is locked up. he thinks, anyway has been sitting for more than three years. Please understand i have not touched it yet but if his description is accurate im looking for suggestions on freeing it up before  having to tear it down. I'm hoping to get some great info from the pros on Quadcrazy.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...