Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Tom Blank

2018 570 Sp EPS

Recommended Posts

I know this seems to be a problem at times but how often has anyone had the fuse blow on their EPS? Mine did the first time 15 minutes after I bought it when unloading it off the truck at home. Should I be worried about it blowing often or is it just a rare occurrence? 

Share this post


Link to post
Share on other sites


Talk to dealer. Should be under covered warranty. At least have them check it out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By Stephen Daugherty
      I'm joining to get help and opinions on my z... I just had the entire bottom end and carb rebuilt new rings and plug rose it maybe 4 hours and on the way home it backfired and blew the carb boot from the head and now it won't start? Getting fuel and fire but when I check the plug its covered in fuel? I've checked time and clearance everything seems to be fine? Just cant figure it out?
    • By Wolds Alpacas
      Hello - I have just had delivered my 2004 registered King Quad 300.
      The gear change is pretty fierce.  Pretty hard to get into gear from neutral on the foot pedal and when I select reverse on the hand lever, it jumps into reverse with a hell of a kick.
      I am waiting for a service manual to arrive, but in the meantime, has anyone any suggestions please?
      Thank you.
    • By Ajmboy
      One of my good friends just added this 2018 Textron Wildcat XX to his garage. He already has an RZR and a few quads but said he only wants to ride this thing now because it’s that awesome. I’m still waiting to find some time and go out with him and hit the trails. Here’s some pics..



       
    • By bradleyheathhays
      '11 Grizz 700 here.  Since I've got some warm weather these next couple days I've decided to start the bike after about a year of just sitting.  Took out the plug and sprayed a good amount of fogging oil on top of the piston to help lubricate things.  After about a minute of letting it soak I stuck my air line tubing in to suck out the excess, but it seems like I didn't get nearly as much in return.  Repositioned the tube enough so that everything that was gonna come out pretty much did.  I'll probably shoot some compressed air down the plug hole before doing the start just to make sure it's all out, as well as cranking it for a second before putting the plug back in.   How long would it take for a bit of standing fogging oil to seep past the piston rings, and where would it go?  I guess into the engine oil?  The oil was fairly new the last time it was started but I'm sure it could stand to be changed after sitting for so long.  If much of this fogging oil got into the engine oil should I do the change before the startup?
    • By DKW
      Just got the above mentioned quadrunner. First one ever. Always been a small engine tinkerer but figured I'd need a little help on this one. 

  • Recently Browsing   0 members

    No registered users viewing this page.


×