Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

amelia slabbert

2003 YAMAHA RAPTOR 660R Carburetor problem

Recommended Posts



It may be getting too  much air,  running too  lean to  start  .. Try  replacing the air filter  and other stock inlet air components and see it if starts and runs much better. Some quads  need the  air filter installed to  run  properly. Several  members have run into that  problem  before.

 

 

Edited by davefrombc
  • Like 1

Share this post


Link to post
Share on other sites

As a general rule, spraying carb cleaner through the carb into the engine does no good. The carb cleaner goes directly into the engine without cleaning the passages in the carburator. If you suspect the carb is dirty, you can either remove it and clean or try a gas treatment such as Seafoam or Mechanic in a Bottle.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, wildthang said:

As a general rule, spraying carb cleaner through the carb into the engine does no good. The carb cleaner goes directly into the engine without cleaning the passages in the carburator. If you suspect the carb is dirty, you can either remove it and clean or try a gas treatment such as Seafoam or Mechanic in a Bottle.

Thanks I'll try that.

Share this post


Link to post
Share on other sites


you definitely need the filter and inlet tubes connected, the carburetor needs the vacuum created by the restriction of air from air filter to work properly. 

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Jacob Anderson said:

you definitely need the filter and inlet tubes connected, the carburetor needs the vacuum created by the restriction of air from air filter to work properly. 

Good point @Jacob Anderson 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      Working on my oldest son's buddy's 2000 Big Bear.  He was having some power loss at WOT so i thought it worth while to clean the carb and put at kit in it...or at least clean the OEM jets and use the new orings that come in the kit.  It starts and idles like a champ, but dies and wants to backfire with any throttle at all.  I assume lean because it will run decent with the choke on. Air screw adjusted fine, nice crisp idle.  This one has fuel/air screw, low speed jet, mid jet, and main jet.  I was assuming just trash in the low speed circuit so pulled it and cleaned again, still does the same. 
      Two questions I guess:
      1. Does it sound most likely trash in the off idle circuit?  This one has a few more passages and jets than I'm used to...and a darn diaphragm.
      2. It now really wants to leak at the bowl drain screw.  It doesn't seem to tighten enough to completely stop the flow.  Seat looks good, screw was dirty but cleaned up fine with a touch of 2000 grit paper.  First for me.  Any idea here?
    • By Brian Simmons
      I put on a new stater  , How would my Yamaha raptor 350 act if the starter clutch went out ??? Please help !!! There is no metal in oil . Its like when you hit the starter button nothing ? Any ideas ???
       
    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By HeWasRidinDirty
      I got this 400, that wouldn't start. It would try, but wouldn't catch. I checked the valves and the L intake was tight at .002. The compression came in around 120. It didn't improve after a couple of drops of oil into the cylinder. So,I figured it was the valve causing the problem. So, I got the valves squared away, but it still won't start. I checked the spark and it seems like it's getting an intermittent spark. It fires a few times then nothing. If l let up on the button and then hit again immediately, it will fire a few more times, then repeat. So, what am I looking at as a possibility? Electrical issues are not my strong point. LOL
    • By fox300exchic
      Let's hear all there is to know about you ladies! Where your from and where you've lived. Kids or no kids. What you do for a living. Why you ride and how you got started.
  • Similar Tagged Content

    • By Brian Simmons
      I put on a new stater  , How would my Yamaha raptor 350 act if the starter clutch went out ??? Please help !!! There is no metal in oil . Its like when you hit the starter button nothing ? Any ideas ???
       
    • By orvilleortiz538
      Hey Frank I posted some pictures of my stator from my Raptor660r and I need some help,here are some pics of the numbers I got from the stator the 494 is ok,that's from the white/red & white/green wires but from the white to white I was getting no reading and from the blue and red wires also no reading, so it's most likely done right?


      Sent from my SM-N950U1 using Tapatalk
       
    • By Ankromsathome
      Purchased a 2008 Yamaha Raptor 250 for my son about 1 year ago and have been having problems with the starting system ever since.
      Since owning for one year we have gone thru 2 starters and 2 starter gears. Now its spring 2019 and time for a third replacement. Am starting to think that we may have a more serious issue.
      Upon replacing, the starter and starter gear, its starts fine, then after about 10 starts, you start to hear a bit of grinding. The grinding slowly gets worse until the teeth on the starter and the starter gear become trashed.
      I've heard possible solutions from the starter clutch needing replaced to the casing for the starter gear shaft being out of spec?
      I've also noticed that here is no difference or change if its in gear or not.
      I just replaced the trans clutch as well.
      Any suggestions?
       
    • By frank marano
      View File 1997-2002 Yamaha Raptor Supplementary Service Manual
      1997-2002 Yamaha Raptor Supplementary Service Manual
      Submitter frank marano Submitted 11/24/2018 Category Yamaha ATV  
    • By frank marano
      1997-2002 Yamaha Raptor Supplementary Service Manual
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...