Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

dirtdevil96

Can anyone help me with jetting?

Recommended Posts

I just installed a new full system exhaust and a K&N filter on my '07 Arctic Cat DVX400.It uses a Mikuni brand carb.I installed the recommended 150 main jet before I started it.(Stock is 130)I started the engine and the head pipe turned orange hot.Is this a sign of too rich?Should I go to a lower size main jet or is there another adjustment/jet that needs changed?

Share this post


Link to post
Share on other sites


actaually for most aftermarket exhaust on 4 strokes the head pipe will turn cherry red...ive heard this b4 not a big dealsigns of running rich or lean will be backfiring...

rich will backfire out the exhaust pipe and lean will backfire out of the carb/airbox...hope that helps.. if your bike isnt backfiring id say your fine...

Share this post


Link to post
Share on other sites

I think I found out why it's turning colors.I didn't adjust the fuel mixture screw.On my quad;there's a cap I have to remove(damn you EPA lol)to be able to access the mixture screw.I was told by the exhaust manufacturer that I would only have to rejet the main(they never said anything about the mix screw).I sent a message to Dynojet and they said to get the most power I need to change the needle also.They've been MUCH more helpful than the manufacturer(they even have a Q&A forum-what a waste of my time that was!!).So I think I'm gonna order the Dynojet kit and maybe a couple more things while I'm at it.Thanks to all who replied...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By JacobSlabach
      First of all sorry I have been MIA here for a while, been busy with school and work.  I'll try and reply on some other threads asap, but posting this one because I just picked up a 2017 sportsman 570 before the new year and popped a boot on it going through a mud hole.  The former owner had aftermarket axles on it to accommodate the 4in lift and idk what brand they are but they're skinny as heck and idk what boot to buy to rebuild with?  It's the rear right lower boot (under the brake calp.).  I'll post some pics when I can and sorry again I've missed yall on the forum!
    • By bradleyheathhays
      I have an '02 Taurus with 85k miles on her that I just bought.  Today when I was checking something under the hood I noticed this metal line cold and dripping with water...
       

       
      I had the air on but turned to the position of arrows pointing out of the dash and floor vents only.  The defrost or a/c function was not selected.  It seems to be doing it consistently.  I haven't traced all the parts of this car's a/c system yet but I don't know of anything else under a hood that turns cold and sweats.  Why would my compressor be working when it's not selected?  What tests should I run?
       
       
       
       
    • By Buick350X
      Exploiting a loop hole in the law, turn 4 wheeler into rev trike
      for a long while I have been trying to get a real 4 wheeler street legal.
      the problem is with the state laws, if it has 4 wheels, its a car and has mega more rules.
      If it only has 3 wheels, its a trike and can be made from cobbled junk parts held together with duct tape and they will plate it
      I wonder if anyone would have insight on changing a 4 wheeler over to a single rear wheel?
      [ I can't afford some $40-60,000 canam or super bike modded into a car, rev trike kit ]
      I want something I can truly ride year round on and off road. Ive rode enough old Honda 3 wheelers that I know I do not want a traditional motorcycle trike. So the single wheel has to go out back.


    • By lanow
      Hi Everyone,
      I am new to this forum and hope that someone out there can help me, I have an early Suzuki King Quad 300 (280cc) which starts intstantly every time but at about half revs or there abouts it starts spluttering and will not rev any higher, this fault is present whether choke is applied or not, some one suggested that silencer maybe be clogged so removed baffle but no improvement have removed carb and stripped 3 times but still no joy.
      Any ideas would be most welcome.
      Cheers Rob
  • Similar Tagged Content

    • By Thumpinhard25
      First thanks for any help guys, new to the forums and it's gotten me this far. I bought a 2001 bear tracker 250 for my family to get around the dirt bikes races. It wasn't running right and had a high idle. Previous owner thought it was a carb problem, so he ordered a new Zoom carb and new intake boot, but it still had the same high idle. ( I believe he had the throttle cable adjusted wrong, because it idled fine when I put it back together) So I tore down and cleaned the stock carb, and it started up and idled fine, but needed to have the choke 1/2 out to run.  I swapped to the new zoom carb and had the same issue. Choke half out bike ran ok. I played with the needle and the pilot screw with no change. ( bike did seem to be running rich though, but didn't get better when I tightened pilot screw or raised meddle) I Took it to the races and once I started bouncing around in the cattle fields the quad started cutting out real bad. It would barely run.  Sometimes it would run with choke off, sometimes choke 1/2, sometime choke full. I cleaned carb again, checked float level, and boots, no change still wouldn't run. Then suddenly it started running ok again.  This makes me believe it's an electrical issue rather then carb. I know there's no air leak, it's been checked, both carbs are clean( I've swapped them out a couple times, it starts up immediately and usually idles fine. But then bogs down/ or stutters under throttle. I saw the post on the guy who disconnected his rectifier and reconnected and suddenly it started working again, which lead me to believe it may be electrical and not carb.  So any advice on what I should check? Any way to test the CDI or rectifier?  Once again, I appreciate your help.  
    • By OmarTrx450er-09
      MY trx has some mods like an full exhaust air filter and an oil filter my lid is on i bought a dyno jet kit stage 2 i read the instructions and changed the main jet supposibly but i didnt change any fuel needel on pilot jet when i turn on the bike its starts immidiatly but starts poopin and crackin on 5th gear when i go fast >>>?? why ...i feel like the bike should get some moore airshould i remove the lid or what??
    • By marioweldinginc
      I know Im detuning but its getting annoying riding with an open airbox. I ordered a closed lid cuz sucking in water is not fun. I have the chain drive apart and im waiting for my 13t front sprocket to come in. That should make up for any torque loss with the closed box right?
      My questions are, while I have the carb apart for its winter cleaning do I have to rejet for the closed lid? It already has a Dynojet stage 2 kit in it. Also should I go back to the colder spark plug (DPR8Z). In there already is a DPR9Z
    • By predrider305
      I was looking into learning how to jet a carb since it seems to be a very important part of the atv world! Found a few good pages about jetting and have a question. How would I increase the jet size on a pilot or a main jet? Would I have to buy new jets or is there a certain procedure to do so on the stock jets? Thanks.
      P.s: try to lean any replies towards a beginners point of view
    • By KFx400jim
      I have a 2004 KFX. I am throwing a white bros rd4 slip on for now. I know about the company already lol. I just got a screaming deal on it. My question is this:
      From stock, how many jet sizes should I go up to get this thing to run correctly? Everything else is stock, engine wise at least.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...