Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Chris Davis

Location of cdi box 2003 arctic cat 400 376cc

Recommended Posts

I just got a 2003 arctic cat 400 and I'm having a time finding where the cdi box plug is located. Guy said he took it off and forgot where it was located. Made no sense to me but hey what do I know. Any help would be appreciated.

  • Haha 1

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By BosoxBruce
      Recently I noticed gas leaking from under the gas tank on my 2005 250 2x4. As I looked closer it appears to be leaking from the shut off valve under the tank. It's the valve with the handle that can be turned to open, close or reserve. Can this part be replaced? Thank you.
    • By Scott Sirr
      I need to figure out how to clean/fix or replace my neutral switch assembly On my 2008 Yamaha big bear 400 as generally the neutral light doesn’t come on when it is in neutral. To get it to come on I have to wiggle the foot shifter and hold it in just the right spot.
      I have googled it and can’t find much on the 400’s. I can’t find a service manual online and the parts manual is super vague.
      I think it is in the right side engine cover area, but not certain. 
       Any help would be great. thanks
      Scott
    • By YamahaGrizzly
      So my Yamaha grizzly 700 wasn't going into reverse for some reason but Jon and George figured it out on what to do to fix that problem for me. Jon Talks about how he was able to fix that problem my Yamaha Grizzly was having with the reverse.
      On a side note we are so close to 1k subs! hell ya!
    • By YamahaGrizzly
      Billy went all out and bought N2deep Snorkels, Rubber Down customs Rad kit and Rox speed fx Risers for his Grizzly 700. It took a solid 3 days in the shed to install all this new gear on Billys Yamaha grizzly 700! We cant wait for the next time we get out and go on a run! should be this week actually! gonna be good to get the Yamahas grizzlys and Kodiak together!
    • By HeWasRidinDirty
      I got this 400, that wouldn't start. It would try, but wouldn't catch. I checked the valves and the L intake was tight at .002. The compression came in around 120. It didn't improve after a couple of drops of oil into the cylinder. So,I figured it was the valve causing the problem. So, I got the valves squared away, but it still won't start. I checked the spark and it seems like it's getting an intermittent spark. It fires a few times then nothing. If l let up on the button and then hit again immediately, it will fire a few more times, then repeat. So, what am I looking at as a possibility? Electrical issues are not my strong point. LOL
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...