Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

It was bone dry when I got it. I put a little fuel in it and the filter leaked. So I changed that. And all the lines.

Sent from my SM-N920V using Tapatalk

Share this post


Link to post
Share on other sites


Today i ordered the carburetor for the Raptor660,some very nice blue and black handle bar grips and a carburetor Jet kit from 6sigmajetkit a race carburetor jet kit stage 1-7 and also bought a carburetor for the Kymco Maxxer 300cc then my next purchase will be some good tires.... Any suggestions on Tires for my 660R!!! %

Share this post


Link to post
Share on other sites
Sweet. I hate the anxiety of waiting on parts lol. Keep us posted. 
You ain't lying Frankie!!!! Come on!!! Checking the mailbox 3-4 times a day or calling the wife.... Are the parts there yet? Have you seen a usps or FedEx truck any packages on the porch? Are you sure honey? Check again!!!! LOL.... Some parts store had the carb for the 660 for $560 I was like WTF No way!!! But Im gonna go with Dunlop Tires Original from stock....I will post pictures soon,and the Kazuma Falcon 150cc is getting built already... i got everything original from Kazumausaparts.com...

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites


Sounds great.   Check letgo and CL for atv tires as well as amazon. Great prices.   

  • Thanks 1

Share this post


Link to post
Share on other sites

Started working on the Kymco's Plastics,still have a long way to go, but little by little I will have them looking SHINY!!! again for sure,I've been having a blast with this quad and so have my babies, they are 2 years old Twins, Boy&Girl but loving the rides...But Daddy here is thinking about fixing the Raptor660.... just passing the time and also building the Kazuma Falcon 150cc and fixing all the smaller quads,I cannot believe I own 7 Quads.... and sold 3 already, so imagine how pissed off is my wife with all this things in the back....Lol... Patiently waiting for parts for the #YamahaRaptor660

20190317_094259.jpg

20190317_110215.jpg

20190317_172235.jpg

20190317_190945.jpg

Share this post


Link to post
Share on other sites
18 minutes ago, orvilleortiz538 said:

Started working on the Kymco's Plastics,still have a long way to go, but little by little I will have them looking SHINY!!! again for sure,I've been having a blast with this quad and so have my babies, they are 2 years old Twins, Boy&Girl but loving the rides...But Daddy here is thinking about fixing the Raptor660.... just passing the time and also building the Kazuma Falcon 150cc and fixing all the smaller quads,I cannot believe I own 7 Quads.... and sold 3 already, so imagine how pissed off is my wife with all this things in the back....Lol... Patiently waiting for parts for the #YamahaRaptor660

20190317_094259.jpg

20190317_110215.jpg

20190317_172235.jpg

20190317_190945.jpg

Great progress on the bike.What are you using on the plastics? 

As far as the seat cover goes you can make your own out of some fabric with a T 50 staple gun and scotch guard water repellent spray.   It takes literally 30 mins to do and looks amazing.  

Sounds like your having fun. Keep up the good work. 

 

  • Like 1

Share this post


Link to post
Share on other sites

I havnt had a bike with bad looking plastics so far, but I'm interested in how you did that too..  Improves the look soo much- went from a bike I wouldnt want to a bike I'd pay some $$$ for.

Share this post


Link to post
Share on other sites

Well I cleaned it up with soap and water first,then at Home Depot I got me some Boiled Linseed oil(has to be Boiled) Paint Thinner and some rags and a brush with strong bristles,since the Bike was left outside for I don't know how long, but it was bad,I washed it first,take all the dirt, grime off,then I mixed Both my chemicals Thinner and Boiled Linseed oil and brushed away hard,then,I did this because its for me,I lightly scraped it with a blade made for window scraping,but its very light though,then lastly I may go with the Heat gun,or maybe I'll polish it, don't know yet,but just so you know its not finished yet,I will post the finished product,and its gonna be EPIC!!!! I'm gonna have those plastics SHINY!!!! Then it'll be time for the YAMAHA RAPTOR 660R!!!! to get the plastic done!!!! This is just me doing this like this,people usually just do the Paint Thinner and Boiled Linseed oil and thats it,Im just a perfectionist,cant do half ass crap... My Father's Words "Son if YOU!!! are going to do Something do it Right or Don't do it at ALL!!! Or Let Someone else Do it" that was my Father's sayings....

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites


Lol well said.  Looks great.  I have to say as much as I have worked to buy, sell, upgrade and buy the bikes I wanted with the money I made I am always looking for a new project. It’s a lot of fun.   

Share this post


Link to post
Share on other sites

paint thinner?  that would put me off thinking it would eat the plastics- but I guess thats kinda the goal here.

you could probably use brake fluid too- that stuff eats the finish off everything haha

Share this post


Link to post
Share on other sites

I’ve seen a ton of posts about that paint thinner and linseed oil on YouTube.  I hear good things for short term.  I hear it does not last long. 

Share this post


Link to post
Share on other sites

amazing how cheap parts are for those generic atvs.

Share this post


Link to post
Share on other sites
2 hours ago, Frank Angerano said:

I’ve seen a ton of posts about that paint thinner and linseed oil on YouTube.  I hear good things for short term.  I hear it does not last long. 

That's why i scraped it lightly and then i may use the heat gun or I may polish it,dont know yet..... but you're absolutely right, I watched a bunch of videos on that Paint Thinner/Linseed oil thing and it's kinda weak,and don't last long, but it does wash off alot of the grime and white powdery stuff.....

Share this post


Link to post
Share on other sites


Yep it does. The only thing I can offer is keep it covered in armorall it holds the color.  

  • Thanks 1

Share this post


Link to post
Share on other sites
Yep it does. The only thing I can offer is keep it covered in armorall it holds the color.  
Not bad for a rookie....d6780e3b6e1523f7551be1f4bedd7aac.jpg

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites
might have to use this on some bikes here soon- im hoping to go look at these friday:  https://roanoke.craigslist.org/snw/d/glade-hill-7-various-atvs-sold-together/6848482540.html
guy said he would do $1000
Wow I would dive on that deal head first....sweet, fix a few of those and make most of the money back.....

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites


yea im hoping it lasts till I can get them.....:embarrassed:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Mark Walters
      Hi guys.  First post, hope you can help.  As above 1991 Honda fourtrax.  Starting, running fine until a few weeks ago. Used primarily to put my ski boat in the garage (put 2" ball on front).  Any way, had just backed boat into garage, turned off to crank trailer wheel down, when I went to restart got nothing.  
      No neutral light, no headlights, no reverse light, would not turn over when start button pushed.  It would crank and run when I jumped the contacts on the start relay.  While running the neutral light will come on, although it is dim and flickers.  Reverse light on when running and in reverse.
      What I have done to this point:
      1.  Used jumper cable to ground battery (-) terminal to engine block thinking ground wire from battery to engine may be bad.  No neutral light, no start.
      2. Applied 12 volts to start relay.  Got a loud click like it was making contact.  I didn't have the battery/starter cables connected to the relay, but I am assuming it would have cranked at that time.  
      3. Disconnected neutral switch wire.  Grounded neutral switch wire with jumper wire. No neutral light, no electric start. 
      At this point I am thinking ignition switch vs broken wire in the harness going to the neutral switch (due to dimness and flickering when running).
      Any and all suggestions to help track down this issue are appreciated.
      Thanks
       
    • By uzejo
      My lakota has a new carb and just had a top end redone by a professional, but it will not start. The electric start turns it over great, there seems to be compression. It seems like its trying to start, getting right there and just doesnt catch. It does start occasionally, but wont run for more than a couple of minutes and smells rich. Im assuming the carb needs to be tuned, but im just wondering if anyone else has any ideas before i get a chance to work on it.
       
      Thanks
    • By Ed Zeppeli
      Hi all,

      I picked up this quad after the previous owner couldn't get it going.

      The issue is that I can't get it to fire at idle or at all.

      I've...

      - replaced plug. Decent blue spark. Also tested with spark tester inline.
      - rebuilt the carb. PO had already bypassed vacuum lines from petcock. There's fuel at the cylinder
      - Checked compression with new gauge. reads 190 psi
      - cleaned all contacts I could access.
      - am currently jumping with car battery. Solenoid jumpered.
      - checked cam timing at TDC and adjusted valve lash
      - put gas directly into cylinder to see if it will fire at least momentarily

      Motor turns over well. Plug gets wet. 

      Motor may fire once or twice but smokes through exhaust a bit as if it's trying to fire or combusting.

      This leads me to suspect timing. As mentioned I checked the flywheel mark versus cam marks. Perhaps someone has been in there before because I can't find a 'T' on the flywheel but there is a very visible paint mark which aligns with TDC position on piston. Possibly a slipped flywheel/woodruff?

      Is it possible that if it had seen previous repairs, that the timing could still be off? I'm reluctant to dig into the flywheel/stator area if there's something else I could have missed but all signs point me to that area. Would a bad CDI cause spark timing to be off?

      Anywhere else to diagnose incorrect spark timing?


      I've scoured these forums and elsewhere but I'm posting just in case there's something I've overlooked up until now.

      Thanks very much for reading!


      Warren
    • By Chad Dickerson
      I am goin nuts here! I have a 04 400 air cooled 4x4 , I'm a atv,car,truck,mower mechanic for yrs,just sayin. Ok it cranks and kinda fires now and again then after 5 min of cranking and stopping itl start if u touch throttle itl did then u start all over! If u let it warm up sumtimes u can throttle it up other times it just does! Just depends on it? When it stays running it runs awesome,no problems except it just does randomly like u shut key off? Sumtimes itl start right back up others itl do the no start thing! IV put new plug,adjusted valves and hot tanked carb? I'm at a loss here guys! Please any other ideas? I don't think it's anything to do with flywheel? It's not the auto it has a hi low reverse lever on left fender and foot shifter? Help please lol
    • By JacobSlabach
      i know this isnt an atv but same type of thing.  I have a riding mower im fixing and selling for my aunt and it has a dead battery.  i jumped it off my atv and when i turn the key nothing at all happens.  i tried jumping the relay still nothing.  this is with the seat down.  you wouldnt think this mower would have issues as its a top-of-the-line brand and almost brand new (aunt found it for a good price, still got tits on tires, just sat for a couple months in a mechanic shop
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...