Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

It was bone dry when I got it. I put a little fuel in it and the filter leaked. So I changed that. And all the lines.

Sent from my SM-N920V using Tapatalk

Share this post


Link to post
Share on other sites


Today i ordered the carburetor for the Raptor660,some very nice blue and black handle bar grips and a carburetor Jet kit from 6sigmajetkit a race carburetor jet kit stage 1-7 and also bought a carburetor for the Kymco Maxxer 300cc then my next purchase will be some good tires.... Any suggestions on Tires for my 660R!!! %

Share this post


Link to post
Share on other sites
Sweet. I hate the anxiety of waiting on parts lol. Keep us posted. 
You ain't lying Frankie!!!! Come on!!! Checking the mailbox 3-4 times a day or calling the wife.... Are the parts there yet? Have you seen a usps or FedEx truck any packages on the porch? Are you sure honey? Check again!!!! LOL.... Some parts store had the carb for the 660 for $560 I was like WTF No way!!! But Im gonna go with Dunlop Tires Original from stock....I will post pictures soon,and the Kazuma Falcon 150cc is getting built already... i got everything original from Kazumausaparts.com...

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites


Started working on the Kymco's Plastics,still have a long way to go, but little by little I will have them looking SHINY!!! again for sure,I've been having a blast with this quad and so have my babies, they are 2 years old Twins, Boy&Girl but loving the rides...But Daddy here is thinking about fixing the Raptor660.... just passing the time and also building the Kazuma Falcon 150cc and fixing all the smaller quads,I cannot believe I own 7 Quads.... and sold 3 already, so imagine how pissed off is my wife with all this things in the back....Lol... Patiently waiting for parts for the #YamahaRaptor660

20190317_094259.jpg

20190317_110215.jpg

20190317_172235.jpg

20190317_190945.jpg

Share this post


Link to post
Share on other sites
18 minutes ago, orvilleortiz538 said:

Started working on the Kymco's Plastics,still have a long way to go, but little by little I will have them looking SHINY!!! again for sure,I've been having a blast with this quad and so have my babies, they are 2 years old Twins, Boy&Girl but loving the rides...But Daddy here is thinking about fixing the Raptor660.... just passing the time and also building the Kazuma Falcon 150cc and fixing all the smaller quads,I cannot believe I own 7 Quads.... and sold 3 already, so imagine how pissed off is my wife with all this things in the back....Lol... Patiently waiting for parts for the #YamahaRaptor660

20190317_094259.jpg

20190317_110215.jpg

20190317_172235.jpg

20190317_190945.jpg

Great progress on the bike.What are you using on the plastics? 

As far as the seat cover goes you can make your own out of some fabric with a T 50 staple gun and scotch guard water repellent spray.   It takes literally 30 mins to do and looks amazing.  

Sounds like your having fun. Keep up the good work. 

 

  • Like 1

Share this post


Link to post
Share on other sites

I havnt had a bike with bad looking plastics so far, but I'm interested in how you did that too..  Improves the look soo much- went from a bike I wouldnt want to a bike I'd pay some $$$ for.

Share this post


Link to post
Share on other sites

Well I cleaned it up with soap and water first,then at Home Depot I got me some Boiled Linseed oil(has to be Boiled) Paint Thinner and some rags and a brush with strong bristles,since the Bike was left outside for I don't know how long, but it was bad,I washed it first,take all the dirt, grime off,then I mixed Both my chemicals Thinner and Boiled Linseed oil and brushed away hard,then,I did this because its for me,I lightly scraped it with a blade made for window scraping,but its very light though,then lastly I may go with the Heat gun,or maybe I'll polish it, don't know yet,but just so you know its not finished yet,I will post the finished product,and its gonna be EPIC!!!! I'm gonna have those plastics SHINY!!!! Then it'll be time for the YAMAHA RAPTOR 660R!!!! to get the plastic done!!!! This is just me doing this like this,people usually just do the Paint Thinner and Boiled Linseed oil and thats it,Im just a perfectionist,cant do half ass crap... My Father's Words "Son if YOU!!! are going to do Something do it Right or Don't do it at ALL!!! Or Let Someone else Do it" that was my Father's sayings....

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites


Lol well said.  Looks great.  I have to say as much as I have worked to buy, sell, upgrade and buy the bikes I wanted with the money I made I am always looking for a new project. It’s a lot of fun.   

Share this post


Link to post
Share on other sites

paint thinner?  that would put me off thinking it would eat the plastics- but I guess thats kinda the goal here.

you could probably use brake fluid too- that stuff eats the finish off everything haha

Share this post


Link to post
Share on other sites

I’ve seen a ton of posts about that paint thinner and linseed oil on YouTube.  I hear good things for short term.  I hear it does not last long. 

Share this post


Link to post
Share on other sites
2 hours ago, Frank Angerano said:

I’ve seen a ton of posts about that paint thinner and linseed oil on YouTube.  I hear good things for short term.  I hear it does not last long. 

That's why i scraped it lightly and then i may use the heat gun or I may polish it,dont know yet..... but you're absolutely right, I watched a bunch of videos on that Paint Thinner/Linseed oil thing and it's kinda weak,and don't last long, but it does wash off alot of the grime and white powdery stuff.....

Share this post


Link to post
Share on other sites


Yep it does. The only thing I can offer is keep it covered in armorall it holds the color.  
Not bad for a rookie....d6780e3b6e1523f7551be1f4bedd7aac.jpg

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites
might have to use this on some bikes here soon- im hoping to go look at these friday:  https://roanoke.craigslist.org/snw/d/glade-hill-7-various-atvs-sold-together/6848482540.html
guy said he would do $1000
Wow I would dive on that deal head first....sweet, fix a few of those and make most of the money back.....

Sent from my SM-N950U1 using Tapatalk

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Mike Johnson
      Does anyone know what the 3rd item is behind the battery on this ATV ? I know 1 is the,  solenoid1 is the CDI box, what is the 3rd.
    • By Daniel Gibson
      Working on a bayou 220 that has been ran extremely hard it's whole life. Literally had almost an inch thick dirt/oil covering the motor. Yeah that bad. Surprisingly it runs though. I cleaned the carb and tank multiple times. They're clean enough to eat off of. Readjusted valve lash and set timing. Was about 3 teeth off. It cranks good and runs good only problem is I have to cover the carb intake basically choking the hell out of it for it to start. The com choke works fine. It does this each time I start it regardless of temperature both ambient or motor. Wth? Compression is at 115psi I get 130s if I put a little oil in the piston chamber. Please help. Thanks 
    • By JC4x4
      My Honda Fourtrax won't start. The starter is kicking the engine over, but it won't start. It sat for about a year while I was living away, so I thought it might have been bad gas. I completely drained the fuel, flushed the fuel lines and filled it with fresh gas. However, still nothing. It started and ran fine the last time I used it. Any suggestions on how to diagnose this? It could be fuel or electrical at this point. Is there an easy way to rule one or the other out? Thanks
    • By Quadrunner44
      I have an older 1980s Suzuki quadrunner red lt 4wd (250)
      so just finished putting it all back together and was running fine just needed to adjust the rebuilt carb
      bf decides to hook up an air chuck to the gas tank because it got a shot of air in the gas line well 120psi didn’t agree with any of the parts including the new carb 
      end result : new battery new carb now it just clicks (one single click) won’t turn over 
      hard to pull start gets hung up (unless I remove the spark plug ) gas flooded out the first time but now does nothing purchases a new starter waiting the arrival 
      could there be damage to the crank shaft or pistons etc? Or install the new starter and try to fire it up ? What caused the starter to die after he flooded everything with gas was working fine. 
      Thank you 
    • By bradleyheathhays
      So this '02 Taurus with only 87k miles on her starts right up every time multiple times a day except for twice in the last 3 weeks. The first time was 3 weeks ago and the second was today. It happened the same both times. Turn the key and stop to let the pump prime, then when I turn to the start position the engine turns real slow and sort of in fits. Usually when a battery is low the engine turns slow but in rhythm. During my 2 starts the engine barely seemed to turn and the crankshaft rpm seemed to vary. On both starting events I let off the key and tried to start 2-3 times with rests in between. But then eventually on the 4th try it starts right up just as quickly as a normal start.

      I have No clue as to what might be causing this. Only thing I know to do is, next time it does this to put a voltage meter on the battery to see if it's weak. Actually though, because both events the engine ended up starting up like normal that would indicate something other than the batt. Electrically this car is a little odd though. The interior light never comes on when the doors are opened, for years, and then last week it comes on twice when one of the rear doors is opened.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...