Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Tony Elliott

KFX50 cylinder options

Recommended Posts

Hi Guys

im looking for a 2004 KFX50 cylinder, "i know rocking horse poo". but is the Suzuki LT50 the same? there seems to be a lot of re-pop suzzi stuff out there

Share this post


Link to post
Share on other sites


I know Suzuki made the KFX50 for Kawasaki from '03-'05. Same as the LT-A50.  In '06, Suzuki came out with the LT-Z50 and I don't know if Kaw was still using them or not.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jimsvtx
      I'm working on my brothers' 2002 Suzuki Vinson 500 . It sat for a few years before I got into it. I'm concentrating on the carb - I replaced orings, needle, etc. and soaked jets, bowl and anything that I could get off the carb that the solution wouldn't eat. I also removed the tank and flushed it with hot water - it's clean. The gas cap innards rusted away and the tank had a lot of rust and water in it before I cleaned it. I replaced the gas cap and installed a new fuel valve because the screens were broken in the old one. The bike will run but spits and sputters and backfires. If you "open it up" it falls on its face and stalls - but starts right up. Here is a link to an exploded view of the carb: Ohio Honda Yamaha Motorcycle ATV Dealer - J & J Motors - Kawasaki Suzuki Scooter Utility vehicle, parts, accessories, apparel
      Can anyone point me in the direction of the problem? It may still be a "clean carb parts issue" . My problem is that the parts list doesn't identify the parts to a degree that I understand. If you said" look at the pilot jet", I'm not sure which jet that would be....See what I mean? It'll run very good if I remove the air filter and cover the opening with my hand and part my fingers a little for the air to get in. Any help is greatly appreciated.
      Thanks in advance, Jim
    • By JacobSlabach
      Got a 04 Sportsman 500 that wasnt running- owner said it needed a stater and a new battery.  It ran rough (been sitting out in the weather for a while).  A friend and I started by adding a new battery and it would start barely with the choke and his hand over the air-filter.  I decided to install the new battery in the holder on the side.  we had it on the rack because the old on was still in the bike.  I tried to be nifty by turning the battery to put the terminals in an easier spot to get to, but forgot to reverse the cables too.  In a sentence, I reversed the positive and negative on the battery like a dummy.  When we discovered my mistake and corrected it, we turned on the bike, but the display did not light up and the key did not turn on the starter.  jumping the solenoid worked the starter, so we thought the solenoid just burned up when I reversed the pos and neg...  new solenoid and no difference.  what have I burned up?  Also, the shifter does not seem to do anything in the trans.  it slides back and forth like its stripped in the trans.  any help would be appreciated!!
      I think the biggest issue right now is the electrical.
    • By Lance Workman
      Guys, had a worn smokey recon 250 to the point it it was fouling plugs. Well pulled the jug looked great and believe my culprit was valve seals. They could not even hold the valve in place. So honed the cylinder for good measure and installed new rings while it was apart. Also lapped valves while it was apart due to little corrosion on the intake valve face, went on and did exhuast while it was apart also. Reinstalled everything, adjusted valves, I cant remember how far out they was but they where out a bit. Well long story short it started up, ran great for about 20 minutes and then randomly died while accelerating. Compression is 60 psi at best.... double checked valve lash and it was way out?? Adjusted it, but you can tell its not right. Still no start, and with rockers arms removed still not compression......? Which making believe ring issue? But why is valve lash  all over the place?! Is there an easy way to check cam to crank timing to make sure it hasn't jump time? Thanks!
    • By William Edwards
      Hello,
      I'm new to the site.  My son and I have decided to bring back our old quad from the dead.  Does anyone know where we can purchase a cylinder kit for it.  I think it's a 1986, but will have to check the VIN to be sure.
      The last time it ran, it was tapping and smoking pretty bad.
      Any help would be appreciated.
      Thanks!
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...