Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Bobby Kitchens Jr.

2008 arctic cat 700 efi 4x4 gauge has power, no outputs

Recommended Posts

New arctic cat owner, I've read alot on the gauge issues, but let me say I have power, good ground, the aux also has power, the memory has correct voltage but no output of any kind. Only the LCD color works. I have also fully removed EVERYTHING and cleaned it all... what I still possibly have a cut wire knowing that I have good power to the back of the plug and good ground to the back of the plug but no outputs of any kind?

Share this post


Link to post
Share on other sites


You can download the service manual and wiring schematics here:

https://www.mymowerparts.com/pdf/Arctic-Cat-ATV-Repair-and-Service-Manuals/

 

I would verify first that you do indeed have AUX power, popping that fuse would give you a blank display but it would still light up. 

Two common issues to look at, one is a broken wire in and around the steering column. The schematics will help you verify which pin does what for the gauge cluster.

If it is the gauge itself, try this trick. disconnect both battery wires and connect them together, leave it overnight, then re-connect them, If the gauge isn't fried, this will reset it.

My bet would be a broken wire, seems to be a common problem in 2006 - 2009 Cats. I had a 2007 model that had serious harness problems. Was easy enough to fix with the schematics and using some spiral wrap and loom to protect it, never happened again.

Mike

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Erik Plug
      Hi all,
       
      Picked up my first Brute Force yesterday. What should have been an awesome afternoon of riding turn a bit into a deception. As I was unable to really take it out for a test drive at the shop, I decided to buy it and agreed that I would take the test drive at home. 
      When giving full throttle I noticed that the Brute was choking and lost all of its powers. Faulty fuel pump most likely. 
      Called the shop and the are coming to pick it up and repair it and bring it back. Good service. Nevertheless feels a bit sour in the mouth as I was told it was a 100% good. 
      Need to have some patience I now before I can really start riding. 
      Cheers,
      Erik
    • By Chase Cook
      Hi I was riding my Honda the other day and I gave it gas for about a quarter-mile just flooring it and then it started to lose power. I pushed it about a mile home which was a pain in the butt but when I got home It still had gas, compression and spark. Do you think the timing jumped possibly?
    • By Rich1028
      Good/Better/Best +1 A-Arms honda 400 X 2008-2014 
       
      What are some of the good, better,and the best 1+ a arms out there?
      where does Houser Racing Fall?
      https://www.houser-racing.com/Honda-400EX-1-Standard-Travel-A-arms-p/030107-01.htm
      JD Performance
      http://www.jdperformance.net/488_Web_Design/a_arms.html
       
      and something found on ebay
      https://www.ebay.com/itm/TRX-400EX-400EX-1-A-ARMS-SALE-SILVER-VEIN-LIFETIME-WARRANTY-GNCC/372763670824?hash=item56ca723928:g:qwIAAOSwJkZddV2x
    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
  • Similar Tagged Content

    • By mikeexplorer
      Came across this site today that has a lot of Arctic Cat information. http://shop.arcticcat.eu/isoled-shop/media/uploads/service_support/?dir=
       
      Mike
       
    • By Admin
      Looking for Arctic Cat ATV VIN (Vehicle Identification Number) Number Decoders? Once you find your ATV VIN number off the tag on your Arctic Cat ATV, you can go to all kinds of websites that have VIN Decoders available. The best ones are backed by the Arctic Cat ATV manufacturer, however there are plenty of aftermarket Arctic Cat ATV VIN Decoder websites on the web. This topic will stay pinned and if you find any to add, please do it with a reply. 
      The following Arctic Cat ATV VIN Decoder websites are available where you can just enter your VIN number and it will shows you some of your ATV model details:
      CycleVIN https://www.cyclevin.com/
      KBB.com https://www.kbb.com/vehicle-history-report/ 
      CARFAX https://www.carfax.com
      autoDNA https://www.autodna.com
      VinAudit http://www.vinaudit.com/
      decodeTHIS https://www.decodethis.com
      VINCario https://vindecoder.eu/
      NICB Theft Check https://www.nicb.org/theft_and_fraud_awareness/vincheck 
    • By Joseph Miller
      Hi guys im new here and ive been doing alot of research on my polaris predator i was wondering if anyone on here has wired a different cdi up on there quad? Not a direct replacement that would simply just plug in. I know my white an w/red wires go to my pulsar my green an blue go to my reverse coil but im unsure which is + and which is ground also brown/w is a ground correct? What about purple? Black goes to my kill switch and red is my 12v supply........then ive got yelloww/red , yellow / yellow that goes to my rectifier..........any input on this subject is greatly appreciated thank you all
    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Andrew Baker
      I need help with wiring on a 1998 (I think, 10th digit of the VIN was W) Bayou. I'm not getting spark, I'm pretty sure it is due to grounds being off because the harness is pretty hacked as far as the electric start and charging system goes. I'm needing a good wiring schematic. I found one online and there are a few things that don't add up on it so I'm skeptical that it is really for my year and model. Any help would be appreciated. Thanks. 
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...