Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Michael Trinity

2007 xtreme typhoon 125cc Quad spark plug

Recommended Posts

Hey there.  I have a problem with finding the rite sparkplug for my 2007 xtreme typhoon 125cc.  No one or place has been able to find the right spark plug for it.  Im hoping someone here may have an idea or can point me in the right direction of where to find one.  The old one said ac 108 and one guy at an auto parts store said it was a 10mm spark plug.  Dont know if that was rite or not.  Also if anyone knows of a website i can download the manual for it, that would be very helpful as well. 

Share this post


Link to post
Share on other sites


1 hour ago, Michael Trinity said:

yes that be it.  Thanks so much.  Do u know where i could find a service manual for it.

No unfortunately, I looked online but didn't see one. 

Share this post


Link to post
Share on other sites


The gap is important but usually its not adjustable on the type of atv you have. You can measure the resistance of the coil, if its infinite resistance then the coil is bad

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Susan Makowski-DeGraw
      My quad runs,  it starts up runs for about 10 minutes and then it dies if you let it sit for 10 minutes it’ll start back up ride for another 10 minutes and then die again, trying to figure out why it keeps stalling
       
       
    • By Ed Morris
      I have a 2001 Quadmaster. Bought it from the original Owner. Its in Excellent condition for a 2001. The guy said there was a carb problem when I bought it. It seems like it is not getting fuel. I took off the tank, cleaned it, replaced the gas with fresh Gas, Installed a New Gas Valve. Then rebuilt the carb with a Carb Kit. Started it up and same damn thing, seems like its starving for gas. It will also backfire out the exhaust while trying to accelerate. Now the weird part. I started it the other day and it ran great. We went for a ride and it ran as if nothing was wrong with it. Started it the next day and back to running crappy again. I was like WTF !!! ... Anyone have any ideas of what the problem could be?
    • By abi
      Hello ladies and gents. Just picked this guy up in October and getting around to doing the required maintenance to make sure everything is right before any long rides or work is done. 
      Some background: I am I believe the 4th owner, (however the 3rd didn't actually ride it). It has unknown hours or odometer due to what appears to be a common issue. 
      I have noticed the fuel gauge doesn't work (just keeps flashing empty),
      I did come across a google search that mentioned these were a common problem but was fixed by replacing the dash (seems like overkill) and another post mentioning someone attempting a fix. 
      Any particular issues on these quads to pay attention to beyond the dash ?
      Going to be replacing the rear tires, oil change, filters and plug. Anything else I should do with an unknown history such as diff flush/change ? 
      I believe there is a service manual here but I need a few more posts. Hopefully this post will drive some answers and more questions I might have. Thanks!

    • By vtech
      I have a 1993 Bayou 400 4x4 and I have no spark. I tried 2 new plugs and nothing still.
      I have checked the CDI black wires to body of the box for continuity and none.
      It turns over but no spark, not sure where to go from there.
      Any advise on what and how to check other components would be awesome.
      Thanks: Garry
    • By texaskaw
      been acting up for a couple weeks.running fine then dies,no spark at plug.wait few minutes start up again runs for maybe hours.also sometimes it will run great then it starts losing rpm.will not wind up to higher rpms then it will pickup and go for awhile.well now there is no spark any time ,nothing....
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...