Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Kristpj

2007 KingQuad 450 electrical issue

Recommended Posts

I know this tooic has been addressed by many, I’ve looked through many forums and pages. I did not find anything like the problem i have.

I have a 2007 Kingquad 450. I have a new fully charged battery. When i turn the key, the dash flashes and seems to struggle before getting fully lite. We can hear a small relay near the computer clicking, i think it is the fuel pump relay. When i turn off the engine kill switch and press the starting button relays click and all the power shuts off, i turn the key off, engine kill switch then start over, power is there. Atv will start with pull start, but not elextricly. if i try to use my winch, all power cuts and engine dies. 

 

Can anyone tell me what it may be? or has anyone fsced an issue like this before?

Share this post


Link to post
Share on other sites


It really seems to me that you have a poor connection someplace. If the battery is fresh  then your loosing power within the harness. I would go get some dielectric  grease and start taking plugs apart and cleaning. Then add grease to the plug and reconnect. Then go to the starter relay and loosen the main battery cables on both lugs, clean and re tighten. Make sure your battery wires are not broken at the crimped part where the connector is on all ends.  Check the main ground wire. Loosen it up clean and tighten.  Lastly is it’s possible that one of your relays weather it be the main starting relay or the neutral safety relay may be bad. Both are not expensive and easy to change.  But start with your connections first. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Locke DoBay
      Hello I'm new here and not sure on where this should be posted but here goes. I have a 2007 Kawasaki 360 4x4, it started to make a small knocking sound and few weeks ago. I checked all the normal things and didn't find anything. I just used it around the house as my yard machine, no real heavy loads or stress on it. And it ran fine with no problems. Well one day I went to roll my yard with my roller that i filled with sand. It put the 4wheeler under a load for the first time, well it ran fine for about 20 mins then i stopped to do something and it started but there was nothing there. It would not rev up enough to engage the belt drive and the knock got a lot louder. Sounds like the knock is coming from the top end. And ideas in where to start. I have worked on some stuff and mechanically inclined just never tore into an engine before.
    • By 87tecate4
      View File 2007-2009 Suzuki KingQuad LT-A450X Service Manual
      Suzuki KingQuad LT-A450X 2007-2009 Service Manual
      Submitter 87tecate4 Submitted 07/14/2018 Category Suzuki ATV  
    • By Shane Stump
      Ok guys needs some help asap ready to set this thing on fire..thing would never start valves were tight i adjusted the calves to correct shims on intake n exhaust have plenty of clearance in between cam lobes n shims..problem is i done set tdc about 10 times now its dead on..will not fire one hiccup sprayed gas into carb while cranking n while not all it does is make a loud backfire n some flames come out. Its like valves are tight but  there not.idk how it could be firing wrong with it at tdc. I need help asap
    • By FlyingJBIRD
      I've bought a used 2007 Polaris Phoenix 200... it's in pretty good shape... but after it starts, warms up, a few minutes of my son riding around yard it will die... it refuses to start back until the next day, then same thing again... I've seen this is a problem but haven't found any real answers... my son is driving me crazy to get him back riding... any help is greatly appreciated...
    • By Ajmboy
      With this cold snap, I noticed yesterday that the battery on my grizzly was a little weak. even clicked a few times before I got it to start. I'm thinking of picking up a batter tender/ trickle charger so was wondering what people use to keep their ATV battery charged up. I was looking at these on amazon. They both have good reviews.

       
      or this one

       
      Kind of like this one because if the accessory plug

  • Similar Tagged Content

    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By scotty2hotty01
      i have a older honda 350 cc quad that seems to start and other days will not.spark seems to be gone and there when it does run.I checked newer coil odd a older yet Honda but no help and idea I going to find the serial number as forget the year but believe around 1995 to 1997 year besides that great quad but cant run it so great this way  and need it for chores around the acreage. Any help would be great. Ive check all fuses as well as the fusable ling which was fine until I screwed with it now need to buy another as have it wired not so safe.I handy but now have copd which takes away the brain power some.Any help would sure be appreciated 
    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By Admin
      View File 2014 Arctic Cat 450 ATV Service Manual
      2014 Arctic Cat 450 ATV Service Manual
      Submitter Admin Submitted 02/08/2019 Category Arctic Cat ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...