Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mikeexplorer

Renovo ATV Cruise For A Cure Ride

Recommended Posts

This is now an annual event which raises money for the Relay For Life to help cure cancer. Over 200 machines plus passengers attend the event. (I don't have the exact count from this year) The whole town of Renovo welcomes the riders for the weekend and there are plans to connect this town to the nearby state trails as part of the "Northcentral ATV Initiative"

 

0608190828.jpg

0608190842_HDR.jpg

0608191108.jpg

0608191208.jpg

0608191352_HDR.jpg

DSCF0089.JPG

DSCF0099.JPG

DSCF0100.JPG

DSCF0103.JPG

DSCF0112.JPG

DSCF0114.JPG

DSCF0140.JPG

DSCF0156.JPG

DSCF0163.JPG

  • Like 1

Share this post


Link to post
Share on other sites


$40 you get the ride (50 miles), a t-shirt, and a chicken dinner after the ride. Good ride and good deal

 

  • Like 1

Share this post


Link to post
Share on other sites

And this happens every year around the first week of June ? I would like to attend the next one.

Share this post


Link to post
Share on other sites

That is really cool!

8 hours ago, Frank Angerano said:

And this happens every year around the first week of June ? I would like to attend the next one.

I might be interested as well next year. Put it in the calendar: https://www.quadcrazy.com/calendar/

  • Like 1

Share this post


Link to post
Share on other sites


20 hours ago, Frank Angerano said:

And this happens every year around the first week of June ? I would like to attend the next one.

Usually yes. Camping is free but primitive if you sign up for the ride.

Mike

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By chuckufarlie
      I'm looking for people to ride with. I live in the GTA, but often ride Haliburton or Kawartha trails, and have recently discovered a bunch of trails that don't belong to any club, if anyone is looking to ride.
    • By pokolbinguy
      Hi All,
      Following on from the brief interlude in the "introducing myself" thread....
       
      In a nutshell, I acquired a YFM250 Moto 4 (1991) for cheap recently with the previous owner citing "no spark, needs a new magneto coil and I don't have time to fix it"... anyway I am dubious that the magneto/generator is the issue and thinking more along the line of ignition coil as after a clean up of the magneto I was able to get a rather decent voltage reading off the magneto with pull start and resistence readings seem to check out that the magneto is all ok (all 3 x phases = 1.2 ohms and no run to ground)
      None the less I ordered a new Ignition coil and Magneto/generator coil and am waiting for them to arrive.
       
      In the mean time I cleaned up the current Magneto, popped in a new battery and sparkplug, checked out all the wiring harness, all seemed good except I came across the "neutral switch" wire was broken.
       
      After wiring up a new neutral switch wire, the neutral light now comes on  (small win) and the starter relay (attached to rectifier) now clicks. If I hit the starter switch on handle bar the starter motor spins and if I  pull the cord starter I get a spark on pull....YAY!! I'll try and attach a video below if possible.
       
      So onto the starter motor. Starter solenoid seems to work A-ok, even if it looks crappy and starter motor spins as it should when I hit the start switch....but here is my issue.
       
      When the starter motor runs it turns Cog #1 and Cog #2 (see photo below)....but the chain in the back of the starter which I assume is the timing chain, does not move and there is no apparent movement of the piston in the cylinder.
       
      If I turn it by hand (per photo) or with the pull starter however the chain moves and the engine turns. However cog #2 rotates but not fluidly with the "Crank" (part I turn by hand) for the lack of a better word to use if that makes sense?
       
       
      Is there a grub screw or similar on Cog #2 that fixes it to the center shaft to make it all turn when the starter motor is run? Could there be a part missing? Previous owner had the starter apart so could be possible?
       
      The outer/front part seems to be on a key-way so not sure how to remove this easily to check how Cog #2 is attached.
       
      What am I missing here?
       
       
       
       
       

      spark_baby.mpg


    • By bradleyheathhays
      '11 Grizz 700 here.  Since I've got some warm weather these next couple days I've decided to start the bike after about a year of just sitting.  Took out the plug and sprayed a good amount of fogging oil on top of the piston to help lubricate things.  After about a minute of letting it soak I stuck my air line tubing in to suck out the excess, but it seems like I didn't get nearly as much in return.  Repositioned the tube enough so that everything that was gonna come out pretty much did.  I'll probably shoot some compressed air down the plug hole before doing the start just to make sure it's all out, as well as cranking it for a second before putting the plug back in.   How long would it take for a bit of standing fogging oil to seep past the piston rings, and where would it go?  I guess into the engine oil?  The oil was fairly new the last time it was started but I'm sure it could stand to be changed after sitting for so long.  If much of this fogging oil got into the engine oil should I do the change before the startup?
    • By Rick Shropshire
      Happy New Year all! Remember not to operate any vehicles while under the influence, you could get busted or worse, you could get hurt or hurt someone else who's playing it safe and end up in jail. Have fun and be safe.
    • By stymy68
      So I'm trying to figure out the year of one of my Timberwolf's. I have 4.
      2 are definitely 1993's, as I can read the serial number on those.
      1 has to be close to a 93, as the back rack and lug width (156) are the same as the 93's.
      The last one is killing me. Someone painted over the serial number.
      Listed are the differences
      Back rack is different. It goes through the plastics and will pivot on the rear attachment. Doesn't have the handles out the side, either.
      Doesn't have the loops coming out of front plastics.
      Foot rests are different.
      Lug pattern is 110.
      Everything I've read, says that the Timberwolf was produced from 92-98 and then changed name to Bear Tracker. Most parts are interchangeable through those years. Only change I found, was front brakes were upgraded to disk in 2001.
       
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...