Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Brittany Jones

1998 polaris xplorer 400 4x4 Quad dies

Recommended Posts

Yes I just got a 1998 polaris xplorer 400 4x4. Ran fine after hauling then died. Cleaned carb and put new fuel filter, hose, and new battery in. Starts 3 out of 10 times but will only run for a short time. Any suggestions?

Share this post


Link to post
Share on other sites


Test your spark and not just for a few cranks.  See that it’s consistent. 

If that’s ok check the timing. We hear some of the time people hauling things and you wind up with a jumped timing chain. 

Other then that I would say to look at the carburetor and fuel delivery system if all else checks out. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...