Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Tom W

2009 can am renegade

Recommended Posts

2009 can  am  renegade 800 almost caught fire upon inspection  rubber melted on wires run to battery looked like they chaffed on frame and shorted.... replaced both battery wires and still seeing sparks any ideas??

Share this post


Link to post
Share on other sites


Are you sure the wires are correctly installed. The black bolted to the frame and the red going to a relay with two nuts on it ? 

And did someone possibly install the battery and put the wires the wrong way ? 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Maxx
      Hello Guys!
      Dumb question. How much oil registers on the oil level gauge while running? The oil level reads correct when off, but while running I can only see just a little bit in the oil level gauge. Makes wonder if the oil isn't circulating well enough.
      Also, whats your preference in battery brands for ATV's (standard or AGM). We don't ride it all that often.
      Thanks in advance for any info.
    • By Chase Cook
      Hi I just got an Polaris sportsman 500 4x4 ATV the other day. I got it real cheap but I started to go into it because it didn't have compression so I bought a new piston and ring kit for it and installed it, but now when I try to start it all it does is shoot fire out the exhaust or the intake of the carburetor. And a timing is top dead center.;I think I can't really tell another way if it is or not. when I put it together I made sure to piston was on top and the cam lobes where facing down where are the cam sprocket is facing up. It has gas and spark. It did start a couple minutes ago but it didn't stay running and now it won't start. Do you think the valve need to be adjusted more to close better?I'm fixing to try that out and if that don't work what is the problem? Also I made sure everything was together good and right and change the oil and changed out the radiator fluid.
    • By Ben Mann
      Rincon was stuck in 4x4 so we cleaned the sludge out of the diff, put fresh oil in and all is well.
    • By spock58
      I was reading another forum recently about fuel leaks and possibility of fire happening. Reminded me of an incident I had a few years ago while working at a Can Am dealership. The quad was a stolen & recovered Outlander 650 that had been tampered with. These quads have an electronic safety system, similar to their DESS system on the sleds. You cannot bypass the key switch and get spark without a computer with factory software. Anyway, I was trying to determine what was damaged since the thief had attempted to hot wire various electronic parts. I got all the extra wires removed and things looked back to stock. Pulled the spark plugs and was going to check for ignition and if the starter still worked. Well, they both worked alright and guess what - the cylinder was flooded with fuel! Instant flames with gas spraying all over...great!! I managed to use my hands to put out the fire, good thing I had on gloves (but choked they were ruined of course, haha). Seems it's possible to flood an engine with efi when you put power straight to the injectors, doh! As in much of life, you cannot take things for granted (I'd only seen carbs flood like that). And even though it had spark, the quad still needed a new ECM to run - that part alone was $1200. So lets hear your stories, crazy stuff happens every day I'm sure.
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...