Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

turp

Greasing Yamaha Swing Arms

Recommended Posts

if you have trouble greasing yamaha swing arms .

i tried all kinds of couplers even the spacial locking ones.

what works is alemite 308730 coupler. only paid $8.50 at traction for it.

  • Like 1

Share this post


Link to post
Share on other sites


Moved to yamaha atv forum 😀

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By Nigel Bourn
      I’ve just bought one of these and came here looking for a service manual
      Mine has an air cleaner that I don’t seem to be able to find, it has round ends with square tabs on them, any ideas?
       
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By Vidar Bråten
      Hi 
      Anyone here that know how to find a service maual for Linhai LH 700 ? 
      Please let me know , have been looking for a long time , cant find anything . 
       
      Vance 
    • By goldeneagle
      I have a 2000 warrior thats seems to run fine. But I am having a problem with the gas boiling in the tank. Does anyone else have this problem or can anyone give me suggestions on how to fix this issue? Thanks Bill.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...