Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: Two Yamaha YFZ450 ATVs Stolen

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By jrhoads23
      I picked up a 2017 Polaris Sportsman 850. The previous owner rarely rode it and it only had 53 miles on it (10 hours). I believe the Polaris break in period is something like 250 miles / 50 hours or something like that at which point they suggest doing the first oil and fluid change. My question is should I do it sooner than that? I believe this was manufactured in fall of 2016 so that means the fluids in there are 3 years old. Maybe that isnt a big deal and it is still fine to wait until 50 hours, but just wanted to check
    • By Scott Sirr
      I need to figure out how to clean/fix or replace my neutral switch assembly On my 2008 Yamaha big bear 400 as generally the neutral light doesn’t come on when it is in neutral. To get it to come on I have to wiggle the foot shifter and hold it in just the right spot.
      I have googled it and can’t find much on the 400’s. I can’t find a service manual online and the parts manual is super vague.
      I think it is in the right side engine cover area, but not certain. 
       Any help would be great. thanks
      Scott
    • By marek porowski
      It’s kind of ATV related question as I need new trailer tires to tow my 4 wheeler. 
      Does anybody have any experience with loadstar 12” trailer tires ? 
      There is not to many choices for trailer tires here in Ontario and I was wandering if somebody can recommend me something. 
    • By StolenATV
      Trailer loaded with four wheelers attached to truck in front of our house, . They pulled receiver out spun it around and left.. Came home no trailer or 4 wheelers.
      The post 2 ATVs and trailer stolen appeared first on STOLEN 911.
      View the full article
    • By Daniel Gibson
      Have a 08 raptor brought to me a couple months ago. Got it on a trade for house remodel. Bike has around 30 hours. No that's not a typo thirty verifiable hours. The main Yamaha tech has put hands on this bike. Always Been reallyhard to start. If it does it runs really good. That's the kicker...IF! It started out intermittent now it's no spark at all. Everything ignition related is brand new. It all checks out good but still won't do it. Please help
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...