Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Carl Edouard Denis

2003 Honda TRX650 Idling High

Recommended Posts

Hello to al, ,

First time poster long time ATV rider. I just go a used 2003 TRX650 got the card cleaned and it started up right away. ONly problem I am having is that its idling high. Any ideas as to wy this may be happening?

 

CED

Share this post


Link to post
Share on other sites


Welcome to QUADCRAZY! Have you adjusted the idle screw on the carb? 

Share this post


Link to post
Share on other sites

Have you checked that the throttle cable is not looped up or kinked anywhere ? Check where the cable adjuster is on the  handlebars where the cable enters the throttle assembly.  Make sure nothing is broken. Turn the handle bars back and forth  while the bike is idling and see if there’s any change.  The cable could have been changed and routed improperly.  

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Frank Angerano said:

Have you checked that the throttle cable is not looped up or kinked anywhere ? Check where the cable adjuster is on the  handlebars where the cable enters the throttle assembly.  Make sure nothing is broken. Turn the handle bars back and forth  while the bike is idling and see if there’s any change.  The cable could have been changed and routed improperly.  

That's a good point @Frank Angerano , maybe that cable is hanging up. 

  • Like 1

Share this post


Link to post
Share on other sites


The only reason I could see the idle changing while your shaking the bike is fuel swishing around inside the bowl of the carburetor and somehow making its way up and into the intake portion of the carburetor. Something along the lines maybe a loose jet of some sort inside the bowl.
Secondly would be the main jet needle where it locks into the slide in the carburetor is missing the clip or installed wrong and loose.  

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By Kaj Colum
      Have a Bayou 400. sometimes when I press the start button i hear the solenoid click but the starter does not engage. Here is the strange thing though, when that happens if I kick the kick start just once then press the start button starter engages normally. Any ideas?
       
    • By HeWasRidinDirty
      I got this 400, that wouldn't start. It would try, but wouldn't catch. I checked the valves and the L intake was tight at .002. The compression came in around 120. It didn't improve after a couple of drops of oil into the cylinder. So,I figured it was the valve causing the problem. So, I got the valves squared away, but it still won't start. I checked the spark and it seems like it's getting an intermittent spark. It fires a few times then nothing. If l let up on the button and then hit again immediately, it will fire a few more times, then repeat. So, what am I looking at as a possibility? Electrical issues are not my strong point. LOL
    • By StolenATV
      Attention! Stolen! From a deployed soldier on independence day! 2014 Honda Foreman 500 and 2003 Yamaha 660 Raptor. Please spread the word in helping find them. A report was filed with Franklin County as well.
      The post 2003 Yamaha 660 Raptor and 2014 Honda Foreman 500 appeared first on STOLEN 911.
      View the full article
    • By Venom
      Hi, All

      I started this project a while ago.. I have decided to make one thread I can continuously update..

      So , here we go. I got this Raptor 80 in really bad condition.. Rear end frozen, Engine toast, tires dry rotted, tons of rust..etc.. They admitted they beat on it very hard.

      Since they do not make these with a drive shaft anymore I decided to restore it from top to bottom..

      These are photos of when I got it home.

      Next up, the tear down..



      First, I needed to tear it down and determine if the rear end was still good... As we all know... That is where it would be cost prohibitive to restore if it is trashed..

      Got it completely stripped down and I lucked out... The rear Drum brake was caked solid inside with dried mud. That was causing the rear end to lock up. Took off the rear brakes and the rear end spun perfectly smooth.

      Once I got it all stripped apart I needed to take the finish off all the parts. I am going to be powder coating the frame and many parts.. Once the finish is off each part it will need to be sandblasted to white metal .. The guy I use for powder coating gives me a hefty discount if I bring the parts to him ready to go.

      You could just sand blast, but that would take a long time to get the finish off. First I used Aircraft Paint Remover.. That stuff is pretty toxic Goggles and Resperator are required. That quickly gets you down to the metal... Then you can sand blast to white metal pretty quickly...


      I had another thread I had started about a problem with the tear down... It has some great info .... here is the link... It is about removing the frame bushings. ....
       
      https://www.quadcrazy.com/atvforum/topic/14209-raptor-80-frame-bushings/?tab=comments#comment-104702
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...