Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Hi everyone.

Currently have a 2004 King quad 300 4wd.

There's a few parts I need to get 4wd working again and also have a crack in the engine crankcase(big trucking rock). 

Replacement engines are horribly expensive so looking for a half decent site to buy parts /kits that also have detailed diagrams and part numbers.

Going to disassemble weld crack and give the engine a freshen up.

 

Any recommendations please

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Unfortunately I didn't notice some of the rust hitting the undercarriage of my 2004 Yamaha Grizzly 660, but saw it the other day when I was doing some maintenance, oil change, air filter, spark plug, etc. The left side footrest broke and that's causing the plastic to hit the front wheel. It broke right at the welds from too much rust. Looks to me like what I need is (looked this up on yamahapartshouse.com):
      YAMAHA FOOTREST BOARD 5KM-27481-10 Left side (broken)
      YAMAHA FOOTREST BOARD 5KM-27488-10-00 Right side (rusted and will probably break eventually)

       
      Does anyone have a less expensive source? I did see on ebay a couple of listings but it still comes out to @ $50 each, 
    • By DUBLT
      Looking to purchase a windshield for my ATV, suggestions of what to buy with quality in mind and will fit without doing any modifications. 
    • By Ted Aregi
      I've got a king quad 750cc has anyone converted the fuel pump relay to a stronger fuel pump relay on there king quad?
    • By josephnbl91
      My four wheeler when i first got it seemed like it was very slow when i first got it and it had no throttle response so i replaced the belt and cleaned all of the rollers thinking that would solve the problem from what i read on the forums. well it turned out that it wasnt. so i went to the next thing i took out the injector to check it out and i seen that there was a tiny bit of debree in it so i cleaned it and it seemed to improve a little bit. but still did not solve the problem. i later found out how to find the trouble codes out from the lcd screen using a paper clip on the diagnostic port and it showed the code which stood for no codes C00. i also forgot to mention that the throttle position censor is working perfect. before i started all of this the four wheeler ran just not to its potential. after my friend and i did the trouble code test the bike wouldnt even start anymore and the injector would spray for a few seconds for the start up then it stops and the fuel injection light comes on and blinks. the four wheeler wouldnt start anymore. i took it over to the local shop and they hooked it up to the computer to see if there was any codes and it still showed it was free of codes. they hooked it up to the fuel pressure gauge and we found that it was making 22 pounds and it should be making around 43. i then bought a new fuel pump and put it in. it now starts and runs for a few seconds and then it stalls out and the fuel injection light comes on again. which then leads me to think it is the ecu now but i want to be sure before i invest around $500 more into it. any opinions on whether or not anyone thinks this is the problem or if they have had a similar problem before would be really appreciated. sorry for writing a novel and not spelling very well. also i forgot to put the year in the title it is a 2007
    • By Juan Gutierrez
      hello all. i have a suzuki lt230e engine. hopefully i can get it to drive some wheels soon.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...